Author Topic: Cannot Request Trial License  (Read 2343 times)

Offline EddieA

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Cannot Request Trial License
« on: July 18, 2012, 01:33:49 pm »
I have just installed the latest flexRAID and am unable to generate the information required for a Trial License.  When I select Request Trial License, I get a pop-up that reads:  Trial request pre-registration failure!

This is a clean install of Slackware 13.37 in an ESXi VM specifically to take a look at flexRAID.

I turned all the logging options I could find to TRACE, and have included the log file here.  I have a feeling that this is the issue:
Code: [Select]
[2012-07-18 11:13:06,984] ERROR: Error while executing the external command-line process. Message=null
com.tchegbe.a.a.b.a: Error while executing the external command-line process. Message=null
at java.lang.Void.<unknown>(Unknown Source)
at java.lang.Void.<unknown>(Unknown Source)
at java.lang.Void.<unknown>(Unknown Source)
at java.lang.Void.<unknown>(Unknown Source)
Caused by: java.lang.NullPointerException
... 4 more
But there is no clue as to what the failing command is.

Cheers.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Cannot Request Trial License
« Reply #1 on: July 18, 2012, 01:42:39 pm »
Are you entering the correct sudo password?

Offline EddieA

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: Cannot Request Trial License
« Reply #2 on: July 18, 2012, 02:37:23 pm »
Are you entering the correct sudo password?
Yes.  If I enter the correct one, I get that error after a couple of seconds.  If I enter garbage, then it takes quite a while before I get the error.

Also, that error occurs in the flexRAID startup, before I even start a browser session.

Cheers.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Cannot Request Trial License
« Reply #3 on: July 18, 2012, 04:54:37 pm »
It is occurs before you open the browser and request a trial, then it is unrelated to your issue.
I don't see in the logs where you are making a request for the trial.

Offline EddieA

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: Cannot Request Trial License
« Reply #4 on: July 18, 2012, 06:11:25 pm »
OK, so I tried again.  Here's the log, plus a screen shot showing where I was.

Just for grins, I might try downloading the Zentyal server and try with that also.

BTW.  Just to confirm, I'm using the sudo password for the user that flexRAID is running as.  I tried with that once, which gave the screen I captured.  I then tried with the password of the user running the browser.  That just kept cycling though the progress bar screen endlessly.

Cheers.

Offline EddieA

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: Cannot Request Trial License
« Reply #5 on: August 17, 2012, 05:13:54 pm »
To answer my own post, in case it helps anyone else.

The issue was caused by the PATH that is available for sudo, which FlexRAID obviously uses.  Adding the following to my /etc/sudoers fixed the issue:
Code: [Select]
Defaults secure_path="/bin:/sbin:/usr/bin:/usr/sbin"Cheers.