Author Topic: Issue with RT Raid and Filesync programs  (Read 1402 times)

Offline radio1one

  • Newbie
  • *
  • Posts: 12
  • Karma: +1/-0
    • View Profile
Issue with RT Raid and Filesync programs
« on: September 20, 2012, 06:14:29 am »
Hi All,

Been using FlexRaid for over a week now, and the more I read of it the more I love. I've already bought 2 licenses for my main computer and storage server.

But I have run into one issue - when I try to transfer a large amount of files, my FlexRaid drive goes read-only. Before I get into the issue, first my specs: I'm running Windows 7x64 SP1 on a Core i7-3700k with 32gb Ram, with Version 2 update 9 final of FlexRaid installed. I've got 3x2tb drives in my RT Raid / Storage pool - 2 DRU's and 1 PPU, configured using the do's and don'ts specified in the Wiki, with a file allocation size of 512kb.

So what I'm doing is transferring 2tb from my old computer (soon to be the storage server) via a 1gbit ethernet connection using Syncback to manage the file copy process. I've also used MS SyncToy, which gives the same result.

After a period of time, the FlexRaid will become read-only - I can still create folders, rename, delete - but I can't with files. I keep getting a permissions error. Going into the Web Console is no help - I get an error (can't remember it but it is repeated here on the forums - to which the solutions have been to clear the browser's cache, but that hasn't worked here). So I have to stop and start the FlexRaid service to get back into the Web Console, but then I can't start the storage pool.

To get that running, I have to restore the storage pool's backup, and then run a reconcile task, followed by a forced sync. Obviously, this takes a long time, but at the end, I'm able to start up the FlexRaid storage pool and continue with my copying until it happens again.

Has anyone else seen this behavior, and is there a fix? It's going to be annoying to have to reconcile the storage server when it comes into play like this as there will be lots of people writing and reading to it at once.

Thanks,

Alex

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Issue with RT Raid and Filesync programs
« Reply #1 on: September 20, 2012, 07:40:53 am »
The best tool to copy into an RT RAID pool is actually Explorer. It seems that many of the tools out there fail to pre-allocate for the files to be copied and end up creating far too much fragmentation into the file system. Either the program pre-allocate or you should serialize its operation (have it copy one file at a time).

Dealing with excessive fragmentation is one of the TODOs for RT RAID.