Author Topic: Can't activate old license  (Read 5587 times)

Offline costateixeira

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Can't activate old license
« on: October 29, 2012, 05:05:04 pm »
Hi

I'm trying to activate FlexRaid. I bought the license already some time ago. I already changed the activation window.
Now, when I enter the purchase code and the sudo password to activate, the web frontend gives me an error "0" on the lower right corner, and on the terminal window where i manually started FlexRAID I see:

root@server:/var/lib/flexraid# ./FlexRAID &
[1] 9996
root@server:/var/lib/flexraid# FlexRAID initialized successfully....
Exception in thread "qtp-424934424-27" java.io.IOException: Bad sys info query! => [null] -> 0
    at java.lang.Void.<unknown>(Unknown Source)
    at java.lang.Void.<unknown>(Unknown Source)
    at java.lang.Void.<unknown>(Unknown Source)
    at java.lang.Void.<unknown>(Unknown Source)
terminate called after throwing an instance of 'ErrorMessage*'


I'm using Ubuntu 12.04 (64bit) and the latest of FlexRaid.

Any ideas?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Can't activate old license
« Reply #1 on: October 30, 2012, 09:39:41 am »
Make <install root>/ext/NativeIOE executable.

Offline costateixeira

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #2 on: November 29, 2012, 02:31:38 pm »
Hi

It is executable. Doesn't work. Updated to r11, and i cannot activate my product.
Any ideas how to solve this?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Can't activate old license
« Reply #3 on: December 02, 2012, 09:22:03 pm »
Hi

It is executable. Doesn't work. Updated to r11, and i cannot activate my product.
Any ideas how to solve this?

What OS are you running?
If the file mentioned is executable, make sure the user running FlexRAID has execution permission on it.

Offline costateixeira

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #4 on: December 03, 2012, 08:50:06 am »
Hi Brahim

The file is executable. It's actually +r+w+x for everyone.
I had this in Ubuntu, now retried in xbmcbuntu. 
I cannot get over this - always the same error.
How can I get FlexRaid to work on Linux?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Can't activate old license
« Reply #5 on: December 04, 2012, 06:55:48 am »
Try a standard Ubuntu install.
If it is not working, it has to do with your environment.

Also, try a standard install of FlexRAID by installing to your home directory (for testing).
Basically, copy the installer to your home directory, execute, and accept the default.

Offline costateixeira

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #6 on: December 06, 2012, 10:27:55 am »
Hi

That is what I have been trying so far. Ubuntu Linux 12.04, then changed to another version.
I am using an HP  Microserver N40L.

I tried to install FlexRAID to both /home/me.. and to /var/lib/FlexRAID. Result is the same.
Any  ideas?

Offline costateixeira

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #7 on: December 08, 2012, 05:03:36 pm »
Just one thing:

Everything seems to be working. The only thing is the activation that somehow crashes the app.
Neither online or offline activation works. The rest seems to work OK.

Offline RobRum

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #8 on: December 09, 2012, 06:51:05 pm »
I'm having the same problem.. Ubuntu 12.04 server, 64 bit, Webmin.

FlexRAID 2.0 Final Update 11 for Linux installed as per the post here - http://www.havetheknowhow.com/Configure-the-server/Install-FlexRAID-v2.x.html

I've tried making the /ext/NativeOSE file executable. I've tried installing into /home instead of /var.

Requesting a trial licence works fine, but whenever I try and Register Online or Download Pre-registration Info I get the error message attached, and the line "terminate called after throwing an instance of 'ErrorMessage*'" in the terminal.

Contents of trace log suggest there's a problem with the Sudo password, but this is definitely correct. Log is attached.

Offline costateixeira

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #9 on: December 10, 2012, 04:28:25 am »
Hi

Just to check permissions, I actually logged in as root and did everything as root - install, GUI... so there was no need for sudoing.
The same issue appeared.


Offline tomspices

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #10 on: December 30, 2012, 04:43:56 am »
Hello, was there any resolution for this issue?

I ask as I'm having a similar issue when using my newly received payment code.
(Flexraid u11 on Ubuntu 12.04 server, xfce).

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Can't activate old license
« Reply #11 on: December 30, 2012, 07:23:40 am »
Hello, was there any resolution for this issue?

I ask as I'm having a similar issue when using my newly received payment code.
(Flexraid u11 on Ubuntu 12.04 server, xfce).
Actually, no.
If you don't mind, let setup a remote session after the holiday for me to look at your system.
Install teamviewer and PM me the connection info.
I haven't tested the latest Ubuntu build yet, but I will next week to see what might have changed.

Offline astagg

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #12 on: December 31, 2012, 05:47:52 am »
Having the same issue on trying to activate on a new code (trial was working but now expired)

Have sub'd to this post so anyone that finds a solution please come back and post here.


If this could be an issue in the latest versions is there any archived downloads of previous versions that could be used in the time being?

Offline costateixeira

  • Newbie
  • *
  • Posts: 7
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #13 on: January 02, 2013, 04:24:48 am »
Hi All,

I noticed something that can be useful to address this. Can someone see if they have a similar configuration?
The issue:
My drives were formatted as NTFS, which for UBUNTU means for default that the device will be mounted for read only access to everyone but the owner.
The solution(for my own purposes, unrelated to FlexRAID, but maybe this can solve the problem)
I started by adding full permissions to my /etc/fstab for my FlexRaid disks (data and parity)

UUID=xxxxxxxxxxxxxxxxxx   /media/Disk1   ntfs-3g   rw,auto,user,uid=1000,gid=1000,umask=000,fmask=0111,dmask=0000,permissions,users,utf8   0   0
UUID=yyyyyyyyyyyyyyyyyy   /media/Parity   ntfs-3g   rw,auto,user,uid=1000,gid=1000,umask=000,fmask=0111,dmask=0000,permissions,users,utf8   0   0

This now allows drives to be read/write.

I wonder if this fixes the issue. Can someone please check if this could be it?

Cheers


Offline Costalat

  • Newbie
  • *
  • Posts: 47
  • Karma: +1/-1
    • View Profile
Re: Can't activate old license
« Reply #14 on: January 02, 2013, 06:57:00 am »
Well, glad to see that there are other users trying to get Flexraid running on xbmcbuntu :)

Last week I installed the OS, today I will try to get Flexraid trial running. If all goes well, I'll try to register my license.

I'll report my findings soon (hopefully)