Author Topic: Can't activate old license  (Read 5588 times)

Offline eriknorthrop

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Cant activate!!!!!!!!!!!!!!!!!!!!!
« Reply #15 on: February 04, 2013, 09:35:28 pm »
I have a very similar error....

root@g5:/var/lib/flexraid# ./FlexRAID &
[1] 2789
root@g5:/var/lib/flexraid# FlexRAID initialized successfully....
Exception in thread "qtp-428584696-27" java.io.IOException: Bad sys info query! => [null] -> 0
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
terminate called after throwing an instance of 'ErrorMessage*'

I have Ubuntu 12.04.1 64 bit, 32 bit libs installed and a JRE. No matter what i do, i just cannot activate FlexRAID. See the screenshot of the GUI error message.

Has anyone solved this or know how to fix it?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Can't activate old license
« Reply #16 on: February 05, 2013, 10:06:49 am »
Make sure the exes in <installation root>\ext are all executable by the user running FlexRAID.

Offline eriknorthrop

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
CANNOT ACTIVATE
« Reply #17 on: February 05, 2013, 10:30:50 am »
I changed a few files to execute under my account (not root) in the ext folder. I then used the following command.... ./FlexRAID & See below for result

flexraid$ ./FlexRAID &
[1] 6576
erik@g5:/var/lib/flexraid$ log4j:ERROR setFile(null,true) call failed.
java.io.FileNotFoundException: /tmp/FlexRAID.log
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
FlexRAID initialized successfully....
Exception in thread "qtp-428584696-26" java.io.IOException: Bad sys info query! => [null] -> 0
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
terminate called after throwing an instance of 'ErrorMessage*'
^C
[1]+  Aborted                 (core dumped) ./FlexRAID



I ran the same command but using sudo... se below

flexraid$ FlexRAID initialized successfully....
Exception in thread "qtp-429633272-27" java.io.IOException: Bad sys info query! => [null] -> 0
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
terminate called after throwing an instance of 'ErrorMessage*'
^C
[1]+  Exit 134                sudo ./FlexRAID



I then ran the same command at root... see below

flexraid$ sudo su
flexraid# ./FlexRAID
FlexRAID initialized successfully....
Exception in thread "qtp-429633272-27" java.io.IOException: Bad sys info query! => [null] -> 0
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
terminate called after throwing an instance of 'ErrorMessage*'
Aborted (core dumped)

 
Each time I am getting the same error message on the GUI registration page.

Here are the file permissions for the install directory: flexraid/ext$ ll


total 7468
drwxr-xr-x 8 erik erik    4096 Feb  4 21:08 ./
drwxr-xrwx 6 root root    4096 Feb  4 21:09 ../
drwxr-xr-x 2 erik erik    4096 Feb  4 21:08 at/
drwxr-xr-x 2 erik erik    4096 Feb  4 21:08 err/
-rwxr-xr-x 1 erik erik   67287 May  1  2012 fusermount*
-rw-r--r-- 1 erik erik     288 Nov 10 10:42 l.dat
-rwxr-xr-x 1 erik erik  538529 May  1  2012 libfuse.so*
-rwxr-xr-x 1 erik erik  764986 Apr 19  2012 libJetCallback.so*
-rwxr-xr-x 1 erik erik 2725672 Nov 10 09:59 libNativeOS.so*
-rwxr-xr-x 1 erik erik  397724 Nov 10 11:28 libview_class1_0.so*
-rwxr-xr-x 1 erik erik  397724 Nov 10 11:28 libview.so*
-rw-r--r-- 1 erik erik     288 Nov 10 10:42 ll.dat
-rw-r--r-- 1 erik erik      21 Nov  6  2011 mount-extra-params.txt
-rwxr-xr-x 1 erik erik 2518712 Nov 10 10:00 NativeOSE*
-rwxr-xr-x 1 erik erik  144796 Nov 10 10:38 nio.so*
drwxr-xr-x 2 erik erik    4096 Feb  4 21:08 rc/
drwxr-xr-x 2 erik erik    4096 Feb  4 21:08 smart/
-rwxr-xr-x 1 erik erik   24677 May  1  2012 ulockmgr_server*
-rw-r--r-- 1 erik erik       0 Nov  6  2011 unmount-extra-params.txt
drwxr-xr-x 2 erik erik    4096 Feb  4 21:08 vc/
drwxr-xr-x 2 erik erik    4096 Feb  4 21:08 vr/


Thank you for helping BTW.

Erik
« Last Edit: February 05, 2013, 10:41:30 am by eriknorthrop »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Can't activate old license
« Reply #18 on: February 05, 2013, 11:58:31 am »
Try install and running as root (just to see if that makes a difference).

Offline eriknorthrop

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #19 on: February 05, 2013, 12:26:03 pm »
Same errors. Same everything?

Erik

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Can't activate old license
« Reply #20 on: February 05, 2013, 12:58:48 pm »
Same errors. Same everything?

Erik

Quote
/var/lib/flexraid$ log4j:ERROR setFile(null,true) call failed.
This tells me you have a bad install.
Most likely, the working directory is wrong.

Offline eriknorthrop

  • Newbie
  • *
  • Posts: 13
  • Karma: +0/-0
    • View Profile
Re: Can't activate old license
« Reply #21 on: February 05, 2013, 01:02:18 pm »
Are you referring to FlexRAID or the OS?

Is there another directory or method i should be using to install FlexRAID. The guide i am using is here...http://www.havetheknowhow.com/Configure-the-server/Install-FlexRAID-v2.x.html

The last time, i did not change any file permissions. I stared and completed the entire process as root.

Erik