Author Topic: FlexRAID configuration WIPED? 0 out of 0 bytes available!?  (Read 4138 times)

Offline bjoure

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« on: November 06, 2012, 06:20:13 pm »
This looks bad. My config was running without any problems until I need to fix some Windows 8 permissions issues -- so I took ownership of the whole C:\ including the log files at root C:\. Then I restarted. The next thing I know my whole configuration is GONE. Well I don't believe it's truly totally gone -- too scary a possibility -- I don't know how to fix whatever problems I may have caused with my changing permissions.

PLEASE HELP! :-[ :-[ :-[

logs:
https://www.dropbox.com/s/fsybu0i1tpyurqu/FlexRAID.log

https://www.dropbox.com/s/tx63wgfl5awo3af/FlexRAID.sys.c1-1.log
« Last Edit: November 06, 2012, 06:24:33 pm by bjoure »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #1 on: November 06, 2012, 06:27:53 pm »
Yep, you have prevented FlexRAID from accessing your drives with that move.

Offline bjoure

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #2 on: November 06, 2012, 06:48:16 pm »
Thanks for the prompt reply! How do I change it back? Is the default owner of log files SYSTEM or something else?

Offline bjoure

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #3 on: November 06, 2012, 07:14:09 pm »
I shut down my PC and I don't want to change anything until I have an official answer...

Offline DrBlaze

  • Sr. Member
  • ****
  • Posts: 281
  • Karma: +14/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #4 on: November 06, 2012, 10:08:09 pm »
The problem isn't log files.  Flexraid mounts your drives to a hidden place on your c: drive.  When you changed permissions Flexraid lost access to the drives. 

In the pic you posted there is a "delete configuration" button up top. Delete your configuration, then create a new one like you did at the very start.  Add your drives back in the same order you have them now.  Make H: your PPU again, and when it asks if you want to use the parity data it found there say yes.  It will then instantly re-create the array and you should be right back where you started.  It should only take you a few minutes.
« Last Edit: November 06, 2012, 10:10:11 pm by DrBlaze »

Offline bjoure

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #5 on: November 07, 2012, 12:20:34 am »
I deleted the configuration, but my hard drives did not reappear in File Explorer, even after a reboot. I think they are still "hijacked" for a lack of a better word by FlexRAID. So I cannot recreate another configuration just like it or access my files for now. I assume there's an easy solution to this? Btw I cannot delete the log files on root C:\ due to permission issues I am having.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #6 on: November 07, 2012, 12:32:56 am »
You just have to undo the permission changes.
I guess I came in too late to tell you not to delete the configuration.
The permission issues prevented FlexRAID from returning you your drives.

You will have to go to the Windows disk manager and assign drive letters to your drives and remove the FlexRAID folder mounts.

Offline DrBlaze

  • Sr. Member
  • ****
  • Posts: 281
  • Karma: +14/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #7 on: November 07, 2012, 07:50:22 am »
Sorry bout that :-[  I figured re-creating the configuration was preferable to messing with permissions again, but I really should have realized that the drives wouldn't automatically re-appear since Flexraid didn't have control of them (I've had to manually remove the Flexraid mounts before as well)

Offline bjoure

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #8 on: November 07, 2012, 09:28:48 pm »
So I am able to reassign drive letters to my hard drives and now they reappear in File Explorer. However the FlexRAID path is still attached to my drives and I cannot remove these paths -- I get a Access Denied error from Virtual Disk Manager.

Offline DrBlaze

  • Sr. Member
  • ****
  • Posts: 281
  • Karma: +14/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #9 on: November 07, 2012, 11:33:58 pm »
So if you go to Administrative Tools>Computer Management>Disk Management, right click on the drive, select "change drive letter and paths" are you saying that you cannot delete the Flexraid mounts?
« Last Edit: November 07, 2012, 11:37:39 pm by DrBlaze »

Offline bjoure

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #10 on: November 07, 2012, 11:43:17 pm »
Yes. Now each hard drive has a drive letter but still has the now defunct FlexRAID folder path (not sure if this is the right technical term). When I select that and click the remove button a dialogue box pops out telling me access denied, the title bar says Virtual Disk Manager.

Offline DrBlaze

  • Sr. Member
  • ****
  • Posts: 281
  • Karma: +14/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #11 on: November 08, 2012, 12:38:47 am »
Can you access the drives (browse)?  If so, try to create a new config and see if they appear normally this time.
« Last Edit: November 08, 2012, 01:27:57 am by DrBlaze »

Offline bjoure

  • Newbie
  • *
  • Posts: 29
  • Karma: +0/-0
    • View Profile
Re: FlexRAID configuration WIPED? 0 out of 0 bytes available!?
« Reply #12 on: November 08, 2012, 01:12:30 pm »
I totally messed up my C:\ permissions so I did a clean install of Win8, and now I know I have the same issues with storage pool functionality in Win8 as many other users. Thanks for your help! I really appreciate it.