Author Topic: Permissions issue - can't figure it out!  (Read 2687 times)

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Permissions issue - can't figure it out!
« on: January 04, 2013, 05:17:15 am »
Hi all,

New to this setup (making progress though)! I have a remaining permissions issue. I can access, edit and delete files but my other users (shared via Samba in ubuntu) cannot. An example is the file below:

-rwxrwxrwx 1 flexraid users  74240 Jan  4 22:10 Project Conical Device Cost Forecast_111212.xls

The other user cannot save the file, i.e. has read only access. I reset it to 777 as it's opens as read only when set to 755.

Also, the user is question is part of the users group and flexraid is the user account that is running flexRAID. Access to other users is also set to 'true'.

On a windows client the dialogue box stats that unix account flexraid needs to grant permission to access it.

Any ideas - a bit of a pain as I can't share files or edit them really which is a bit of a (temporary I'm sure) flaw!

Thanks,

Alex
« Last Edit: January 04, 2013, 05:45:40 am by ajburnet »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #1 on: January 05, 2013, 03:11:48 pm »

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #2 on: January 05, 2013, 07:25:06 pm »
Certainly have. Just checked again to be sure.


Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #3 on: January 05, 2013, 09:06:26 pm »
The secret might be in how you have setup your Samba share permissions.
Try to detail your settings and include screenshots.

1. Screenshot of FlexRAID Run-Time Properties
2. Samba settings
3. A screenshot of "ls -l" issued on the pool locally and then remotely (mapped from the client standpoint)

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #4 on: January 05, 2013, 09:31:52 pm »
Thanks, see attached.

It does look like the permissions are being presented differently to the clients, with (I think!?) no write permission, only read and execute. Appears the owner has write access locally...I think!


Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #5 on: January 08, 2013, 02:42:40 am »
I tried resetting permissions so all files are owned by flexraid and part of flexraid group (which all users are members of). This allows me to delete and edit. However when I copy a new file it is obviously owned by the corresponding user account with default permissions that cause the same problem (example below):

-rw-r--r-- 1 ajburnet root     287307 Jan  7 22:13 Rural_Zones_brochure4 copy.pdf

The example below after resetting all permissions seems to do the job:

drwxr-xr-x 7 flexraid flexraid    408 Jan  6 14:46 Project Conical Device

Any idea why new files have these permissions by default?

Thanks,

Alex.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #6 on: January 08, 2013, 05:28:55 am »
In Linux, files are owned by who ever created them.
You need to change your default permissions so that access is granted by users of the same group as the owner.

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #7 on: January 08, 2013, 07:29:32 pm »
This is what baffles me - all users are part of the users and flexraid groups so they should all have access associated with those groups?
« Last Edit: January 08, 2013, 08:04:54 pm by ajburnet »

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #8 on: January 09, 2013, 09:45:59 pm »
Any thoughts? I'm failing the wife test in that's it's unusable for file sharing purposes as it stands!

Thanks,

Alex

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Permissions issue - can't figure it out!
« Reply #9 on: January 10, 2013, 01:23:46 pm »
Code: [Select]
-rw-r--r-- 1 ajburnet rootMaybe you should give root access to if that's your intent.

Again, it reads to me that you defaults are for your OS to grant only read permission to non-owners.
Change that to grant r/w to all member of a group.
You will need to Google for how to set that up for your OS.