Author Topic: drives still showing at original mounts points  (Read 3731 times)

Offline dynabaul

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
drives still showing at original mounts points
« on: January 28, 2013, 12:44:35 pm »
I have 4 data drives and 1 parity and after i've made the DRUs 1-4 and PPU 1 and start the pool I can see the pool and it's size is correct.  But the drives still show as mounted at their original mount points as well as the flexraid mount points.  And they are accessible in both places as well.

When i go to the drive manager all the drives show as both pooled and unpooled drives.

I've uninstalled flexraid and resinstalled, re-setup the cruise control real time setup and it's the same.

How do i get flexraid to recognize these drives are pooled correctly?

Offline dynabaul

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: drives still showing at original mounts points
« Reply #1 on: January 29, 2013, 11:09:42 am »
I've also setup in winXP and have the same thing.  The pool/raid is there and working but I still see and have access to the drives individually.

What setting am i missing to hide these?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: drives still showing at original mounts points
« Reply #2 on: January 29, 2013, 12:30:37 pm »
Go to your Windows Disk Manager and remove the drive letters.
Make sure to not touch the one created by FlexRAID.


Offline dynabaul

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: drives still showing at original mounts points
« Reply #3 on: January 29, 2013, 01:03:32 pm »
Does the same go for the linux box too?  Remove the original drive mount info from the fstab file?

Offline dynabaul

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: drives still showing at original mounts points
« Reply #4 on: January 29, 2013, 01:38:21 pm »
I removed the drive letters with the XP install and after reboot the raid will not start.  It says it's not initialized.

I try the re-create command under Command Execution Center and I get this error:

Code: [Select]
ERROR: Max DRU size greater than Parity size error! Max DRU=0 Parity=-125829120
The drives still show as their original letter in the Data Configuration for DRU1-4 and PPU1.  They no longer show in the system as expected but FR can no longer see them either in order to start the pool/raid.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: drives still showing at original mounts points
« Reply #5 on: January 29, 2013, 02:34:41 pm »
You will do best by posting screenshots of the Drive Manager to show your configuration.

Offline dynabaul

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: drives still showing at original mounts points
« Reply #6 on: January 29, 2013, 03:50:45 pm »
Here are the shots after I've restored the drive letters to all the drives.  When I removed them they just don't show anywhere like you would expect.  But the raid setup can't see them either when they're manually removed.

V through Y are the DRU drives and Z is parity.  The pool works but the drives stay showing before and after creation of the raid configuration.
« Last Edit: January 29, 2013, 03:53:06 pm by dynabaul »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: drives still showing at original mounts points
« Reply #7 on: January 29, 2013, 04:01:59 pm »
And there you have it...
You are in Expert mode.

Delete the configuration and create a Cruise Control configuration.
Don't use Expert mode until you fully understand FlexRAID.

More importantly, never run RT RAID in Expert mode unless you really really really know what you are doing.

Offline dynabaul

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: drives still showing at original mounts points
« Reply #8 on: January 29, 2013, 04:18:31 pm »
Why would expert mode not hide the actual drives?

On my linux install I am using cruise control mode and the drives still show on their actual mount points as well as in the pool. 

That's why on xp I tried expert to see if it worked better and it behaved the same way.  I did switch to a cruise control mode on xp and they are now hidden as expected.  I'm trying to decide which OS to run my raid on, I really want linux as the OS.  I trust it to be more stable than windows overall.

But now on linux.  I deleted the config and recreated it on linux in cruise control and all drives still show on both their original mount points and in the pool.  I haven't tried removing the fstab entries for them yet, but in the drive manager they show in both the pool and non-pool drive sections.
« Last Edit: January 29, 2013, 04:25:01 pm by dynabaul »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: drives still showing at original mounts points
« Reply #9 on: January 29, 2013, 06:12:16 pm »
On Linux, do not add your drives to fstab as fstab will reconnect them.
What you needed to do is mount the drives only for the session so that FlexRAID could take ownership of them.

So, it is not that FlexRAID is not hiding the drives and more so that you have multiple mount managers (fstab and FlexRAID) doing things to your drives.

Expert mode not hiding drives is by design since it support much more complex configurations.
The option of hiding the drives is left to the user as some users don't want their drives hidden.