Author Topic: Any way to prevent pooled drives from displaying on desktop & nautilus?  (Read 1776 times)

Offline alpharetro

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-0
    • View Profile
I'm a Linux noob, but when I start my machine all my drives auto mount and I see these:




It's a little annoying. I know it can be prevented somewhat by making fstab entries along with "noauto" but I remember Brahim mentioning fstab should never have to be used for Flexraid. Is there some kind of setting that I don't know about?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
If the drives are already in fstab, then you have to edit it to remove them from there.
Drives should only be mounted temporarily for FlexRAID to take ownership.

So, go ahead and remove the entries.
Even if you set to not auto-mount, you will see them listed and could potentially end up mounting them simply by double clicking.

Offline alpharetro

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-0
    • View Profile
My problem is actually the opposite of what you suggested. What you see above is what happens when the entries are removed from fstab. Adding them back with noauto eliminates the issue. It might be something with how Ubuntu handles drives?

I don't know, I guess I can just leave the entries since it doesn't really hurt anything.

Offline MasterCATZ

  • Jr. Member
  • **
  • Posts: 64
  • Karma: +0/-0
    • View Profile
I am currently stuck on the opposite , how to get FLEXRaid Pool to show as a drive

on my test system the flexraid pool showed up as an removable drive .. but on the production system I have to go to where I have it mounted

as for your problem i believe you can just right click and unlock from launcher ?

assuming you are using ubuntu , you can run, disks, more actions , edit mount options , untick always show in user interface


Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Hi - I have a similar problem. I have moved from an Ubuntu 12.04 desktop install to a server install.

On the desktop install the drives disappeared from the file manager when FlexRAID took ownership. On Ubuntu server that doesn't happen and if I accidentally unmount them problem start!

It sounds like actually adding entries into FStab gave you this functionality in effect? Is that right (I have no entries other than my boot and swap partitions in fstab at the moment)?

Thanks,

Alex