Author Topic: Cannot activate installation after purchase of license  (Read 2440 times)

Offline Grasio

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Cannot activate installation after purchase of license
« on: April 12, 2013, 02:12:27 pm »
Hey there guys,

Last night I've purchased the full license for FlexRaid after my trail period ended.
This morning I received the key and I've tried activating FlexRaid so I could enter my data again.

However I seem to be stuck in some kind of loop that does not let me activate the product.

Someone else posted the exact same steps I've taken:
Quote
I bought a license yesterday (RAID F + Pooling), and received the purchase code today. But I can’t seem to get it activated. The steps I have taken are explained below. I would appreciate any help I can get to complete the activation.

1) Downloaded and installed the latest version of FlexRAID
 2) Purchased a license
 3) Opened the FlexRAID UI and clicked on “Register Online”
4) Pasted in the purchase code I received on email and clicked “Start”
An error message popped up saying “Invalid request”, with the title “Operation Failure”.

Then I tried the following:
 1) Registered and logged in on secure.flexraid.com
 2) Opened “Activation Viewer”, selected the (one and only) purchase code, clicked “New Offline Activation”
3) Went back to the FlexRAID UI and clicked “Download Pre-registratin Info”
4) After filling in the purchase code and download path, I opened the text file and copied the code inside
 5) Went back to secure.flexraid.com and pasted in the code I just copied and clicked “Activate”
An error message popped up saying “com.google.gwt.user.client.rpc.StatusCodeException” and “500 The call failed on the server; see server log for details”.

When I check my log files it comes up with:

Quote
[2013-04-12 21:24:16,482] INFO : Setting core service port to 9595
[2013-04-12 21:24:16,482] INFO : Setting Http port to 8080
[2013-04-12 21:24:16,482] INFO : Https port not set. Https requests will not be serviced...
[2013-04-12 21:24:16,482] INFO : Starting FlexRAID...
[2013-04-12 21:24:16,482] INFO : FlexRAID 2.0u11 final [Snapshot 1.4 stable / Storage Pool 1.0 RC / Real-Time 1.0 experimental]
[2013-04-12 21:24:16,482] INFO : Started: 12 april 2013 21:24:16 CEST
[2013-04-12 21:24:16,514] INFO : Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
[2013-04-12 21:24:16,514] INFO : Quartz Scheduler v.1.8.4 created.
[2013-04-12 21:24:16,514] INFO : Registering Quartz shutdown hook.
[2013-04-12 21:24:16,514] INFO : Using thread monitor-based data access locking (synchronization).
[2013-04-12 21:24:16,545] INFO : Removed 0 Volatile Trigger(s).
[2013-04-12 21:24:16,545] INFO : Removed 0 Volatile Job(s).
[2013-04-12 21:24:16,545] INFO : JobStoreTX initialized.
[2013-04-12 21:24:16,545] INFO : Scheduler meta-data: Quartz Scheduler (v1.8.4) 'flexraid' with instanceId '1'
  Scheduler class: 'org.quartz.core.QuartzScheduler' - running locally.
  NOT STARTED.
  Currently in standby mode.
  Number of jobs executed: 0
  Using thread pool 'org.quartz.simpl.SimpleThreadPool' - with 3 threads.
  Using job-store 'org.quartz.impl.jdbcjobstore.JobStoreTX' - which supports persistence. and is not clustered.

[2013-04-12 21:24:16,545] INFO : Quartz scheduler 'flexraid' initialized from default resource file in Quartz package: 'quartz.properties'
[2013-04-12 21:24:16,545] INFO : Quartz scheduler version: 1.8.4
[2013-04-12 21:24:16,560] INFO : Freed 0 triggers from 'acquired' / 'blocked' state.
[2013-04-12 21:24:16,560] INFO : Recovering 0 jobs that were in-progress at the time of the last shut-down.
[2013-04-12 21:24:16,560] INFO : Recovery complete.
[2013-04-12 21:24:16,560] INFO : Removed 0 'complete' triggers.
[2013-04-12 21:24:16,560] INFO : Removed 0 stale fired job entries.
[2013-04-12 21:24:16,560] INFO : Scheduler flexraid_$_1 started.
[2013-04-12 21:24:16,576] INFO : jetty-7.x.y-SNAPSHOT
[2013-04-12 21:24:16,576] INFO : started o.e.j.s.ServletContextHandler{/,null}
[2013-04-12 21:24:22,598] INFO : Started SocketConnector@0.0.0.0:8080 STARTING
[2013-04-12 21:24:30,403] INFO : F3
[2013-04-12 21:24:31,527] ERROR: C:\flexraidkey
java.io.FileNotFoundException: C:\flexraidkey
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
[2013-04-12 21:24:31,527] WARN : Exception while dispatching incoming RPC call
com.google.gwt.user.server.rpc.UnexpectedException: Service method 'public abstract com.tchegbe.flexraid.client.bean.ActionStatus com.tchegbe.flexraid.client.rpc.login.LoginService.importKey(java.lang.String,java.lang.String)' threw an unexpected exception: java.lang.RuntimeException: C:\flexraidkey
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
Caused by: java.lang.RuntimeException: C:\flexraidkey
   ... 4 more
Caused by: java.io.FileNotFoundException: C:\flexraidkey
   ... 4 more
[2013-04-12 21:24:36,164] ERROR: C:\flexraidkey
java.io.FileNotFoundException: C:\flexraidkey
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
[2013-04-12 21:24:36,164] WARN : Exception while dispatching incoming RPC call
com.google.gwt.user.server.rpc.UnexpectedException: Service method 'public abstract com.tchegbe.flexraid.client.bean.ActionStatus com.tchegbe.flexraid.client.rpc.login.LoginService.importKey(java.lang.String,java.lang.String)' threw an unexpected exception: java.lang.RuntimeException: C:\flexraidkey
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
Caused by: java.lang.RuntimeException: C:\flexraidkey
   ... 4 more
Caused by: java.io.FileNotFoundException: C:\flexraidkey
   ... 4 more

I've tried different paths for the key file both it did not make a difference.
After some time I tried requesting a new key but another key does not seem to make a difference either.

The biggest problem I have now is that I'm unable to get to my data without mounting the disks under windows and I would like to prevent that as long possible.

Is there anyway you guys could figure out what is causing this? I've paid $59,95 for a product that I currently cannot use :(

Thanx in advance
« Last Edit: April 12, 2013, 02:26:59 pm by Grasio »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Cannot activate installation after purchase of license
« Reply #1 on: April 12, 2013, 03:08:05 pm »
You need to download the latest release.

Offline Grasio

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Cannot activate installation after purchase of license
« Reply #2 on: May 16, 2013, 12:14:56 pm »
Updating did the trick and I'm currently enjoying a fully working product.

Only thing now is keeping the shares after a reboot :P