Author Topic: WHS 2011 Unlicensed after every reboot  (Read 2945 times)

Offline 580guy

  • Newbie
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
WHS 2011 Unlicensed after every reboot
« on: April 14, 2013, 08:14:09 am »
Whenever I Re-boot my server FlexRaid tells me I am unlicensed.

I am running FlexRAID 2.0-Final_u11a.

I have to reset activation and activate online.  When I try to load my FlexRAID key I get the following error with the key on the root of C: drive:

com.google.gwt.client.rpc.StatusCodeException
500 The call failed on the server; see server log for details

Here is the Log excerpt:

[2013-04-14 08:56:19,545] ERROR: C:
java.io.FileNotFoundException: C:
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
[2013-04-14 08:56:19,561] WARN : Exception while dispatching incoming RPC call
com.google.gwt.user.server.rpc.UnexpectedException: Service method 'public abstract com.tchegbe.flexraid.client.bean.ActionStatus com.tchegbe.flexraid.client.rpc.login.LoginService.importKey(java.lang.String,java.lang.String)' threw an unexpected exception: java.lang.RuntimeException: C:
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
Caused by: java.lang.RuntimeException: C:
   ... 4 more
Caused by: java.io.FileNotFoundException: C:
   ... 4 more

The Only way to activate for me is online.   Key will load not matter where I put it or what I type for path.

The other night neither was working and I spent 5 hours trying to protect my array again!
I uninstalled and downloaded the latest version, as someone else suggested to fix the problem.  But every time I reboot the server, FlexRAID reports it's unlicensed!

What's worse is you don't know you're unlicensed until you manually click a command and find out all your data is now unprotected!

I suspected something was wrong when I didn't get any emails for my update schedules.

This is totally unacceptable for a program this price.   Reliability is the MAIN purpose of a software RAID program.

Please fix this ASAP!
Lenovo TS-440 13x2TB 1XSSD | Sans Digital TR5M-B eSATA 5 x 2TB | MediaSonic HF2-SU2S2 eSATA 4 x 2TB | WHS 2011 |Stablebit Drivepool |Stablebit Scanner| FlexRAID 2.0 Snapshot RAID|

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #1 on: April 14, 2013, 08:51:10 am »
Contact sales.
Provide your purchase code and an explanation of your issues.

Offline 580guy

  • Newbie
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #2 on: April 14, 2013, 01:35:28 pm »
Contact sales.
Provide your purchase code and an explanation of your issues.

How so?  Send an email From FlexRAID.com thru the "contact us" link?

Lenovo TS-440 13x2TB 1XSSD | Sans Digital TR5M-B eSATA 5 x 2TB | MediaSonic HF2-SU2S2 eSATA 4 x 2TB | WHS 2011 |Stablebit Drivepool |Stablebit Scanner| FlexRAID 2.0 Snapshot RAID|

Offline b-earl

  • Hero Member
  • *****
  • Posts: 660
  • Karma: +13/-1
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #3 on: April 14, 2013, 02:31:39 pm »
yes or directly to sales at flexraid dot com
Server HW: Chenbro RM41416 case | Supermicro X11SCZ-F + LSI SAS 9305-16i | i3-8300 | 16 GB DDR4 ECC Ram
Server OS:   Windows Server 2016 (UEFI) on  250 GB Samsung 970 Evo M.2 ssd
tRAID 1.1.0 2017.02.11
Backupserver: Supermicro X10SLM-F UEFI + LSI SAS9211-8i IT FW
Server OS: Win 2016 + tRAID

Offline 580guy

  • Newbie
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #4 on: April 14, 2013, 10:35:01 pm »
yes or directly to sales at flexraid dot com

Attempted to send email via "contact us" link at Flexraid.com.

Got error saying "failed to contact mail to server".   

Why is this so hard?
Lenovo TS-440 13x2TB 1XSSD | Sans Digital TR5M-B eSATA 5 x 2TB | MediaSonic HF2-SU2S2 eSATA 4 x 2TB | WHS 2011 |Stablebit Drivepool |Stablebit Scanner| FlexRAID 2.0 Snapshot RAID|

Offline b-earl

  • Hero Member
  • *****
  • Posts: 660
  • Karma: +13/-1
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #5 on: April 15, 2013, 01:20:42 am »
Do not use the contact us but the email from my previous comment
Server HW: Chenbro RM41416 case | Supermicro X11SCZ-F + LSI SAS 9305-16i | i3-8300 | 16 GB DDR4 ECC Ram
Server OS:   Windows Server 2016 (UEFI) on  250 GB Samsung 970 Evo M.2 ssd
tRAID 1.1.0 2017.02.11
Backupserver: Supermicro X10SLM-F UEFI + LSI SAS9211-8i IT FW
Server OS: Win 2016 + tRAID

Offline DoctorTim

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #6 on: April 15, 2013, 07:49:47 am »

Why is this so hard?

LOL, I hear you. The website doesn't really appear to be maintained. The blog is extremely old, the contact form doesn't work, and the registration process seems to fail with a high number of people. Fortunately the forum is mostly helpful. I worry when so many little things are wrong on the front-end with a product that is designed to protect data. Hopefully the attention to detail missing in other areas is not missing in the product itself!

Offline 580guy

  • Newbie
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #7 on: April 15, 2013, 08:08:21 am »
LOL, I hear you. The website doesn't really appear to be maintained. The blog is extremely old, the contact form doesn't work, and the registration process seems to fail with a high number of people. Fortunately the forum is mostly helpful. I worry when so many little things are wrong on the front-end with a product that is designed to protect data. Hopefully the attention to detail missing in other areas is not missing in the product itself!

Yes.  Sure doesn't seem quite ready for prime time yet.   I don't come here often, but when I do, it's always difficult to find what you're looking for, and figuring out where to go next.  Definitely not for the faint of heart!

Have sent an email from my own email client to sales at flexraid dot com (why didn't they just spell it out like that?  Went back to the web site looking for an email link!).   Will post any resolution here to help others that may have this problem.
« Last Edit: April 15, 2013, 10:39:17 am by Brahim »
Lenovo TS-440 13x2TB 1XSSD | Sans Digital TR5M-B eSATA 5 x 2TB | MediaSonic HF2-SU2S2 eSATA 4 x 2TB | WHS 2011 |Stablebit Drivepool |Stablebit Scanner| FlexRAID 2.0 Snapshot RAID|

Offline b-earl

  • Hero Member
  • *****
  • Posts: 660
  • Karma: +13/-1
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #8 on: April 15, 2013, 09:46:00 am »
Well I did not spell it out so spambots do not find the e-mail so easy. Because if the comes spam in that e-mail address then an answer will take longer to get.
Server HW: Chenbro RM41416 case | Supermicro X11SCZ-F + LSI SAS 9305-16i | i3-8300 | 16 GB DDR4 ECC Ram
Server OS:   Windows Server 2016 (UEFI) on  250 GB Samsung 970 Evo M.2 ssd
tRAID 1.1.0 2017.02.11
Backupserver: Supermicro X10SLM-F UEFI + LSI SAS9211-8i IT FW
Server OS: Win 2016 + tRAID

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #9 on: April 15, 2013, 10:43:14 am »
Believe it or not, 90% of mail I get are from the contact page.
I have still not figured out why it works for most and not for some.

I have tested the page myself and it has always worked for me.
Are you guys entering valid email addresses? If not, that might be a reason.

Or maybe it works and give back and error message?

Offline DoctorTim

  • Newbie
  • *
  • Posts: 20
  • Karma: +0/-0
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #10 on: April 15, 2013, 11:41:14 am »
Just tested it, this time on my Mac. I get "Failed to connect to mailserver!" after submitting my info. I used a gMail address and did not supply a phone number. Same error I get on my Windows machine. This of course is no problem for me now because I know to PM from the forum. In case it matters, I am in China and some connections are blocked. E.g. sometimes google related things fail here, in case that helps troubleshoot.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #11 on: April 15, 2013, 12:15:56 pm »
Whenever I Re-boot my server FlexRaid tells me I am unlicensed.

I am running FlexRAID 2.0-Final_u11a.
...
A few notes:

1. The error was telling you  that it was not able to find the file and you were entering an invalid/incomplete path.
I know that these logs can seem cryptic, but do make an effort to analyse the information given to you.

2. Your license became invalid after the OS and hardware changes you made. The process is to initiate a license transfer as documented on the wiki whenever that happens as your license is node locked.

Offline 580guy

  • Newbie
  • *
  • Posts: 49
  • Karma: +0/-0
    • View Profile
Re: WHS 2011 Unlicensed after every reboot
« Reply #12 on: April 17, 2013, 03:37:34 pm »
Finally got a reply from Sales.  They reset my activation so I could activiate successfully on this machine.

I forgot to mention previously, I DID try to do a license transfer, as everything else was failing.  But the portal told me I didn't require a transfer as I was still running on the same machine.  (I only upgraded the OS.)

Anyhow, all is fixed for now. 
Lenovo TS-440 13x2TB 1XSSD | Sans Digital TR5M-B eSATA 5 x 2TB | MediaSonic HF2-SU2S2 eSATA 4 x 2TB | WHS 2011 |Stablebit Drivepool |Stablebit Scanner| FlexRAID 2.0 Snapshot RAID|

Offline NLS

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 1,018
  • Karma: +29/-4
  • Look ma, no hands!
    • View Profile
    • iLogic
Re: WHS 2011 Unlicensed after every reboot
« Reply #13 on: April 17, 2013, 04:42:03 pm »
I am sure ALL the people in Sales rushed to fix your issue.
 ;D
---
NLS
Production system: SBS2011 fully patched, intel Core2 Quad, 8GB, 12 disks (1 system IDE, 1 backup IDE, 10 for array and parity most SATA3), parity is 3TB, largest data disk is 3TB, millions of smaller files, common browser Chrome latest.