Author Topic: SVN Error  (Read 2566 times)

Offline brdhse1

  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
SVN Error
« on: April 18, 2013, 07:35:01 pm »
I see the error below when I try to setup an SVN repo on my Snapshot Pool.  Has anyone else had success with SVN and flexraid?  Is there a setting somewhere that I have to change?

Thanks. 


Code: [Select]
$svnadmin create test
svnadmin: E000009: Can't flush file to disk: Bad file descriptor

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: SVN Error
« Reply #1 on: April 19, 2013, 12:07:49 am »
Which OS?

Offline brdhse1

  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Re: SVN Error
« Reply #2 on: April 19, 2013, 03:03:26 pm »
Ubuntu 13.04 64 bit

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: SVN Error
« Reply #3 on: April 19, 2013, 03:26:18 pm »
Ubuntu 13.04 64 bit
The error states that the file handle used to attempt to flush the file is invalid.
It might have been closed.

Any more detail you could provide?

Offline brdhse1

  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Re: SVN Error
« Reply #4 on: April 19, 2013, 04:15:15 pm »
I cd'd into a folder in my snapshot pool.  I did "mkdir test".  The directory was created, then I issued the command and saw the error in my first post.  Interestingly, the "test" folder was gone after the "svnadmin create test" command. 

I don't know what other info might be helpful?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: SVN Error
« Reply #5 on: April 19, 2013, 10:12:37 pm »
Well, the fact that the file was gone explains the error. There was an attempt to flush a deleted file.
Now, how do we explain that the file was gone?

Offline brdhse1

  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Re: SVN Error
« Reply #6 on: April 19, 2013, 11:39:34 pm »
Quote
Well, the fact that the file was gone explains the error. There was an attempt to flush a deleted file.
I don't understand how the file was gone.  I execute "mkdir test" and the "test" dir did exist. I executed "svnadmin create test" immediately after the "mkdir".  It seems that it was the "svnadmin" that removed the directory, but without knowing the internals of the svnadmin, I really couldn't comment on why it removed the directory. 

I was running a pretty simple test. Are you able to successfully execute this test case on your system?

Offline brdhse1

  • Newbie
  • *
  • Posts: 18
  • Karma: +0/-0
    • View Profile
Re: SVN Error
« Reply #7 on: April 21, 2013, 04:43:16 pm »
Has anyone else had success with SVN?  Is it just something in my setup, or is SVN incompatible with flexraid?