Author Topic: Upgraded FlexRAID...cannot start...  (Read 2158 times)

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Upgraded FlexRAID...cannot start...
« on: April 25, 2013, 02:13:07 am »
Hi,

As I've had a few problems (notifications throwing errors etc.) I thought I should upgrade my version. Which I did following the wiki tips.

However, I cannot start FlexRAID. When starting from the command line I get the following:

flexraid@Labrador:~/flexraid$ ./FlexRAID &
flexraid@Labrador:~/flexraid$ FlexRAID initialized successfully....
Exception in thread "main" java.io.IOException: Missing sudo pass!
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
terminate called after throwing an instance of 'ErrorMessage*'

[2]+  Aborted                 (core dumped) ./FlexRAID
flexraid@Labrador:~/flexraid$

I am running ubuntu 12.10 64-bit. Previous version ran okay albeit with a few minor issues!

Any ideas? Log also attached. Appreciate any help you can provide.

Thanks,

Alex.
« Last Edit: April 25, 2013, 02:22:16 am by ajburnet »

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Upgraded FlexRAID...cannot start...
« Reply #1 on: April 25, 2013, 03:41:20 am »
Okay - it seems it won't run without that error when installed in the home directory - it runs now when reinstalled in /var/lib. Is that right?

Also - the storage pool is set to start at run time but it won't - I have to go into the UI and start it (using Snapshot). Any thoughts as to why this might be?

I had hoped this might resolve the issue I have in that I cannot send email notifications.  I seem to still get the following error:

org.apache.commons.mail.EmailException: Sending the email to the following server failed : mail.seedling.net.au:25

Interesting that I have entered 465 as the port (and checked SSL) but it still reports port 25!?


Thanks again - appreciate any help you can provide!

Alex
« Last Edit: April 25, 2013, 03:46:37 am by ajburnet »

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Upgraded FlexRAID...cannot start...
« Reply #2 on: May 01, 2013, 03:57:16 am »
Further to my last:

I am also seeing this error in the log:

[2013-05-01 18:30:53,227] ERROR:
java.lang.ArrayIndexOutOfBoundsException
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)
   at java.lang.Void.<unknown>(Unknown Source)

Hoping someone has a brilliant idea!! :)

Thanks,

Alex

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Upgraded FlexRAID...cannot start...
« Reply #3 on: May 01, 2013, 07:53:10 am »
You need to provide full logs and more context to the errors.
A snippet does not say much.

Offline ajburnet

  • Newbie
  • *
  • Posts: 42
  • Karma: +0/-0
    • View Profile
Re: Upgraded FlexRAID...cannot start...
« Reply #4 on: May 02, 2013, 03:49:20 am »
I should have mentioned the  server crashed (nothing accessible, including ability to use an ssh session). Log had about 5 lines in addition to that provided below. I have an alert system in place so I know it fell over at 5pm when nothing is scheduled in FlexRAID.

In terms of the context of trying to send email alerts, I have entered the correct account details and attempted to verify and then the other Java related error message was received.

It has also fallen over today (at around midday from the look of my alerts). Full logs attached. This has only happened since the upgrade. Tempted to re-build using OMV at this point although I'd rather avoid it!!

Thanks,

Alex.