Author Topic: FlexRAID does not see my 4TB drive  (Read 2355 times)

Offline lordhypnos

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
FlexRAID does not see my 4TB drive
« on: August 08, 2013, 06:26:49 am »
I recently purchased a Seagate 4TB to replace two 500 GB drives in my storage pool. I deleted the storage pool configuration, removed the old drives, installed the new drive, and formatted it to ext4 just as the other drives. Ubuntu 13.04 sees the drive is every other application, and the settings for the drive are the same as the other drives when viewing the mount options in Disks. However, FlexRAID doesn't see the drive at all (in the toolbox and in the pool-configuration dialogs). Where do I go from here?

Offline lordhypnos

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: FlexRAID does not see my 4TB drive
« Reply #1 on: August 10, 2013, 08:58:00 am »
I ran fsck on the new drive, and no errors were found. GParted shows no issues with the drive (I formatted using GPT partition table). Every other application can see and write to the drive except for FlexRAID.

I'm stumped.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: FlexRAID does not see my 4TB drive
« Reply #2 on: August 11, 2013, 06:29:25 pm »
The only other time I have see this type of issue it was related to partitioning.
Basically, you need to check whether the disk shows at least one partition.

Offline lordhypnos

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: FlexRAID does not see my 4TB drive
« Reply #3 on: August 13, 2013, 07:26:37 am »
Yes, there is one primary ext4 partition on the drive. With it being an advanced format drive, proper partitioning and alignment was the first thing I checked.

Offline lordhypnos

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: FlexRAID does not see my 4TB drive
« Reply #4 on: August 23, 2013, 10:10:10 pm »
I can still use FreeFileSync to backup the files on my storage pool. And I won't have to worry about rebuild time if I pursue that solution.

Has anyone else had success with FlexRAID recognizing a 4TB drive?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: FlexRAID does not see my 4TB drive
« Reply #5 on: August 24, 2013, 10:40:38 am »
The size of the drive has no relevance in FlexRAID.
The issue is somewhere else.

I would try re-partitioning and reformatting that drive (after you backup the data of course).

Offline lordhypnos

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Re: FlexRAID does not see my 4TB drive
« Reply #6 on: September 04, 2013, 07:16:10 am »
I completely uninstalled FlexRAID and removed everything I could find related to it. I reinstalled it, and then I could see the drive. I'm not sure why that happened, but everything works now.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: FlexRAID does not see my 4TB drive
« Reply #7 on: September 04, 2013, 09:56:27 am »
Interesting. It might have been a permission issue.