Author Topic: Need Restore help! INVALID_HANDLE_VALUE ERROR=2  (Read 16057 times)

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #60 on: November 12, 2013, 05:03:00 pm »
The exclusions don't apply during the restore operation.
Will look at the logs a bit later.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #61 on: November 12, 2013, 06:41:04 pm »
logs....  https://www.dropbox.com/s/rsl8dll8697amjc/logs.7z

Exclusion: */.Trash-*;*ü*;*ö*;*ä*;*ß*;*Ü*;*Ö*;*Ä*;*dfü*;*Dfü*;*ñ*;*ç*;*é*;*¤*;*¹*;*à*;*÷*;*.jpg;*.bvr;*tc1*;*tc3*
It is clear that we are having communication issues as to me you seem oblivious as the most apparent things.
Just looking at the logs show the same issue you have been dealing with all along. Nothing will change until you address the real issue.

It is detecting your old files as new. All you did this time is apply exclusions, which you should have absolutely not have done.
The restore operation is the one time where you must absolutely refrain from changing things except as necessary.
Until you can reset your locale or whatever changed back so that it is reading the files as before, a dead horse is being beat here.

Personally, I doubt it is a locale issue.
Why? ANSI file names like this one are being detected as new:
Code: [Select]
/media/truecrypt2/Terra2/-Arbeitgeber/Arbeit Darowski Backup/webcam/CAM/20090616171810/pic1392.jpg
To me, your disk mount points have likely changed.
Between your mixed use of Truecrypt mounting and Linux mounting and whatever else changed, FlexRAID can't find things where they were.
Pulling information out of you is like pulling teeth too. So, whatever logical explanation there is something you are reluctant to come forward with.

In any case, good luck.


Offline wax7

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +0/-0
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #62 on: November 13, 2013, 02:11:22 am »
My language settings , I never changed .

Code: [Select]
mos-r@ubuntu:/media/truecrypt11/test$ grep -H 'LANG\|LC' /etc/environment /etc/default/locale ~/.profile
/etc/environment:LC_NUMERIC="de_DE.UTF-8"
/etc/environment:LC_TIME="de_DE.UTF-8"
/etc/environment:LC_MONETARY="de_DE.UTF-8"
/etc/environment:LC_PAPER="de_DE.UTF-8"
/etc/environment:LC_IDENTIFICATION="de_DE.UTF-8"
/etc/environment:LC_NAME="de_DE.UTF-8"
/etc/environment:LC_ADDRESS="de_DE.UTF-8"
/etc/environment:LC_TELEPHONE="de_DE.UTF-8"
/etc/environment:LC_MEASUREMENT="de_DE.UTF-8"
/etc/environment:LANGUAGE="de_DE:en"
/etc/environment:LANG="de_DE.UTF-8"
/etc/default/locale:LANG=de_DE.UTF-8
/etc/default/locale:LC_NUMERIC="de_DE.UTF-8"
/etc/default/locale:LC_TIME="de_DE.UTF-8"
/etc/default/locale:LC_MONETARY="de_DE.UTF-8"
/etc/default/locale:LC_PAPER="de_DE.UTF-8"
/etc/default/locale:LC_IDENTIFICATION="de_DE.UTF-8"
/etc/default/locale:LC_NAME="de_DE.UTF-8"
/etc/default/locale:LC_ADDRESS="de_DE.UTF-8"
/etc/default/locale:LC_TELEPHONE="de_DE.UTF-8"
/etc/default/locale:LC_MEASUREMENT="de_DE.UTF-8"
/etc/default/locale:LANGUAGE=de_DE.UTF-8
mos-r@ubuntu:/media/truecrypt11/test$ locale
LANG=de_DE.UTF-8
LANGUAGE=de_DE:en
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC=de_DE.UTF-8
LC_TIME=de_DE.UTF-8
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY=de_DE.UTF-8
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER=de_DE.UTF-8
LC_NAME=de_DE.UTF-8
LC_ADDRESS=de_DE.UTF-8
LC_TELEPHONE=de_DE.UTF-8
LC_MEASUREMENT=de_DE.UTF-8
LC_IDENTIFICATION=de_DE.UTF-8
LC_ALL=
mos-r@ubuntu:/media/truecrypt11/test$ ls
demoüöäßÜÖÄ  hier liegt umlautedatei  üöäßÜÖÄ
mos-r@ubuntu:/media/truecrypt11/test$

Only when the restore did not work , I changed settings of FlexRAID . But now reset to its original state as in the previous version . (exept java6, now java7)
The old version did not work because they tried to restore the name too long , and the new version crashes because it can properly deal with the language settings now and therefore now find too many new files. This is stupid.
The integration of the drives are solid and have not changed. I had back then, even extra set a marker so I do not confuse the drives order .
What I would need now is an option in the recovery "skips new detected files on restore".

I add the settings files . that's weird standing in the locale.js file de_DE instead of de_DE.UTF -8 in it so what would be normal and the system settings correspond .
After installing the new version it was even "en_EN"! lol

Since the error my drives are mounted as read-only. it is impossible that a drive has been changed .

Attach: FlexRAID from init.d and Locale.js from /var/lib/flexraid/

EDIT: Forcing now to "de_DE" and trying again.
« Last Edit: November 13, 2013, 02:39:16 am by wax7 »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #63 on: November 13, 2013, 03:55:40 am »
Pay close attention to my notes.
What does a locale setting have to do with a file like "/media/truecrypt2/Terra2/-Arbeitgeber/Arbeit Darowski Backup/webcam/CAM/20090616171810/pic1392.jpg" not being found?
The file path is purely ANSI.

You basically have entire DRUs not being found where expected.

Think on whether you have a combo of issues rather than fixating on just one aspect.
Yes, you had a locale issue restoring some files due to that weird non-standard character.
However, you did not seem to have DRUs not being found then.
Even if you don't run out of memory, you will not be able to restore if the surviving DRUs cannot be found where expected.

Offline wax7

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +0/-0
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #64 on: November 13, 2013, 06:07:46 am »
yes not found, i see that, thats not the outofmemory problem...
Quote
What does a locale setting have to do with a file like "/media/truecrypt2/Terra2/-Arbeitgeber/Arbeit Darowski Backup/webcam/CAM/20090616171810/pic1392.jpg" not being found?
The file path is purely ANSI.
maybe a bad logfile sample, sorry for that! i do lots or restart atm.


done something other, i pulled out the DRu3 NTFS drive for a test run.
looks like 1 step in the right direction and 2 back ;)

https://www.dropbox.com/s/f2khbxeybtgrsru/log4.7z

Code: [Select]
[2013-11-13 11:32:34,220] WARN : Missing: /media/truecrypt2/Terra2/---neu Ausgelager BEarbeiten11/AmiKit-AMIGA/AmiKit/Internet/IBrowse/catalogs/Portugu��s-brasilLooks wrong and right at the same time...  *g*

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #65 on: November 13, 2013, 06:52:28 am »
1. Do make sure to provide clean and relevant logs.

2. You took me too literally on my comment on /media/truecrypt2/Terra2/-Arbeitgeber/Arbeit Darowski Backup/webcam/CAM/20090616171810/pic1392.jpg. When I said not found, I meant that it was being detected as new.

3. No relevant progress on the latest logs. Same old files being detected as new (not where they were supposed to be).
Frankly we are not talking about a file or two. We are talking about either entire DRU or folders within those DRUs.
The name of the files affected are both ANSI and extended.
How you are not able to find the cause of such massive changes is surprising.

Offline wax7

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +0/-0
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #66 on: November 13, 2013, 07:22:56 am »
Quote
1. Do make sure to provide clean and relevant logs.

i am trying but he caps at 20 logfiles

Quote
2. You took me too literally on my comment on /media/truecrypt2/Terra2/-Arbeitgeber/Arbeit Darowski Backup/webcam/CAM/20090616171810/pic1392.jpg. When I said not found, I meant that it was being detected as new.
oh,, new found! now i get it.   Looking at my Logs it sure its ...Terra2/ on the wrong drive now....  dam pool.... but i have a old directory listing somethere...  let me get this to the right drive and i am back to you with the next log if failes....

so, if i move to mutch on my drives (or adding to mutch since last Snapshot)  FlexRAID crashes at restore.... that's a new point for the development ;)

Quote
How you are not able to find the cause of such massive changes is surprising.
its an realy old data combination....  and not all data are from me, Family stuff too... and dam doesnt know wath the kids done.  ::)

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #67 on: November 13, 2013, 10:48:06 am »
Upload your meta file somewhere then PM me with a link to it, and I will get you a listing.

Offline wax7

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +0/-0
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #68 on: November 18, 2013, 03:10:15 am »
Thanks you, sen you the meta file (look PM)

now that i saw the filedate of the meta file, i remember to have renamed some directorys at this time...  *g*  :(



EDIT: first PM doest go tru.....  sended again the link.
« Last Edit: November 20, 2013, 01:00:33 am by wax7 »

Offline wax7

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +0/-0
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #69 on: November 26, 2013, 09:49:48 am »
Thank you for my Filelist.

i moved all files that has been created after the last sucessfull update.

now my log is tiny ;)

but the same OUTOFMEMORY error again!

and after 5 try's it now crashes right away....

Code: [Select]
[2013-11-26 16:40:38,979] INFO : Setting core service port to 9595
[2013-11-26 16:40:38,979] INFO : Setting Http port to 8080
[2013-11-26 16:40:38,979] INFO : Https port not set. Https requests will not be serviced...
[2013-11-26 16:40:38,980] INFO : Starting FlexRAID...
[2013-11-26 16:40:38,980] INFO : FlexRAID 2.0u12 final [Snapshot 1.4 stable / Storage Pool 1.0 stable / Real-Time 1.0 experimental]
[2013-11-26 16:40:38,982] INFO : Started: 26. November 2013 16:40:38 MEZ
[2013-11-26 16:40:39,015] INFO : Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
[2013-11-26 16:40:39,015] INFO : Quartz Scheduler v.1.8.4 created.
[2013-11-26 16:40:39,015] INFO : Registering Quartz shutdown hook.
[2013-11-26 16:40:39,015] INFO : Using thread monitor-based data access locking (synchronization).
[2013-11-26 16:40:39,021] INFO : Removed 0 Volatile Trigger(s).
[2013-11-26 16:40:39,021] INFO : Removed 0 Volatile Job(s).
[2013-11-26 16:40:39,022] INFO : JobStoreTX initialized.
[2013-11-26 16:40:39,022] INFO : Scheduler meta-data: Quartz Scheduler (v1.8.4) 'flexraid' with instanceId '1'
  Scheduler class: 'org.quartz.core.QuartzScheduler' - running locally.
  NOT STARTED.
  Currently in standby mode.
  Number of jobs executed: 0
  Using thread pool 'org.quartz.simpl.SimpleThreadPool' - with 10 threads.
  Using job-store 'org.quartz.impl.jdbcjobstore.JobStoreTX' - which supports persistence. and is not clustered.

[2013-11-26 16:40:39,022] INFO : Quartz scheduler 'flexraid' initialized from default resource file in Quartz package: 'quartz.properties'
[2013-11-26 16:40:39,022] INFO : Quartz scheduler version: 1.8.4
[2013-11-26 16:40:39,033] INFO : Freed 0 triggers from 'acquired' / 'blocked' state.
[2013-11-26 16:40:39,035] INFO : Recovering 0 jobs that were in-progress at the time of the last shut-down.
[2013-11-26 16:40:39,035] INFO : Recovery complete.
[2013-11-26 16:40:39,035] INFO : Removed 0 'complete' triggers.
[2013-11-26 16:40:39,035] INFO : Removed 0 stale fired job entries.
[2013-11-26 16:40:39,036] INFO : Scheduler flexraid_$_1 started.
[2013-11-26 16:40:39,038] INFO : jetty-7.x.y-SNAPSHOT
[2013-11-26 16:40:39,043] INFO : started o.e.j.s.ServletContextHandler{/,null}
[2013-11-26 16:40:39,043] TRACE: keepalive=true
[2013-11-26 16:40:39,043] TRACE: keepalive=true
[2013-11-26 16:40:40,049] TRACE: Executing: smart
[2013-11-26 16:40:40,049] TRACE: => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2013-11-26 16:40:42,207] INFO : Started SocketConnector@0.0.0.0:8080 STARTING
[2013-11-26 16:41:08,754] INFO : Shutting down Quartz...
[2013-11-26 16:41:08,754] INFO : Scheduler flexraid_$_1 shutting down.
[2013-11-26 16:41:08,754] INFO : Scheduler flexraid_$_1 paused.
[2013-11-26 16:41:08,755] INFO : Scheduler flexraid_$_1 shutdown complete.
[2013-11-26 16:41:39,001] INFO : Setting core service port to 9595
[2013-11-26 16:41:39,001] INFO : Setting Http port to 8080
[2013-11-26 16:41:39,001] INFO : Https port not set. Https requests will not be serviced...
[2013-11-26 16:41:39,003] INFO : Starting FlexRAID...
[2013-11-26 16:41:39,003] INFO : FlexRAID 2.0u12 final [Snapshot 1.4 stable / Storage Pool 1.0 stable / Real-Time 1.0 experimental]
[2013-11-26 16:41:39,005] INFO : Started: 26. November 2013 16:41:39 MEZ
[2013-11-26 16:41:39,018] INFO : Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
[2013-11-26 16:41:39,018] INFO : Quartz Scheduler v.1.8.4 created.
[2013-11-26 16:41:39,018] INFO : Registering Quartz shutdown hook.
[2013-11-26 16:41:39,018] INFO : Using thread monitor-based data access locking (synchronization).
[2013-11-26 16:41:39,024] INFO : Removed 0 Volatile Trigger(s).
[2013-11-26 16:41:39,024] INFO : Removed 0 Volatile Job(s).
[2013-11-26 16:41:39,024] INFO : JobStoreTX initialized.
[2013-11-26 16:41:39,024] INFO : Scheduler meta-data: Quartz Scheduler (v1.8.4) 'flexraid' with instanceId '1'
  Scheduler class: 'org.quartz.core.QuartzScheduler' - running locally.
  NOT STARTED.
  Currently in standby mode.
  Number of jobs executed: 0
  Using thread pool 'org.quartz.simpl.SimpleThreadPool' - with 10 threads.
  Using job-store 'org.quartz.impl.jdbcjobstore.JobStoreTX' - which supports persistence. and is not clustered.

[2013-11-26 16:41:39,024] INFO : Quartz scheduler 'flexraid' initialized from default resource file in Quartz package: 'quartz.properties'
[2013-11-26 16:41:39,024] INFO : Quartz scheduler version: 1.8.4
[2013-11-26 16:41:39,030] INFO : Freed 0 triggers from 'acquired' / 'blocked' state.
[2013-11-26 16:41:39,031] INFO : Recovering 0 jobs that were in-progress at the time of the last shut-down.
[2013-11-26 16:41:39,031] INFO : Recovery complete.
[2013-11-26 16:41:39,032] INFO : Removed 0 'complete' triggers.
[2013-11-26 16:41:39,032] INFO : Removed 0 stale fired job entries.
[2013-11-26 16:41:39,032] INFO : Scheduler flexraid_$_1 started.
[2013-11-26 16:41:39,034] INFO : jetty-7.x.y-SNAPSHOT
[2013-11-26 16:41:39,039] INFO : started o.e.j.s.ServletContextHandler{/,null}
[2013-11-26 16:41:39,039] TRACE: keepalive=true
[2013-11-26 16:41:39,039] TRACE: keepalive=true
[2013-11-26 16:41:40,046] TRACE: Executing: smart
[2013-11-26 16:41:40,046] TRACE: => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2013-11-26 16:41:42,204] INFO : Started SocketConnector@0.0.0.0:8080 STARTING
[2013-11-26 16:42:08,773] INFO : Shutting down Quartz...
[2013-11-26 16:42:08,774] INFO : Scheduler flexraid_$_1 shutting down.
[2013-11-26 16:42:08,774] INFO : Scheduler flexraid_$_1 paused.
[2013-11-26 16:42:08,774] INFO : Scheduler flexraid_$_1 shutdown complete.
[2013-11-26 16:42:39,035] INFO : Setting core service port to 9595
[2013-11-26 16:42:39,035] INFO : Setting Http port to 8080
[2013-11-26 16:42:39,035] INFO : Https port not set. Https requests will not be serviced...
[2013-11-26 16:42:39,036] INFO : Starting FlexRAID...
[2013-11-26 16:42:39,036] INFO : FlexRAID 2.0u12 final [Snapshot 1.4 stable / Storage Pool 1.0 stable / Real-Time 1.0 experimental]
[2013-11-26 16:42:39,038] INFO : Started: 26. November 2013 16:42:39 MEZ
[2013-11-26 16:42:39,049] INFO : Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
[2013-11-26 16:42:39,049] INFO : Quartz Scheduler v.1.8.4 created.
[2013-11-26 16:42:39,049] INFO : Registering Quartz shutdown hook.
[2013-11-26 16:42:39,049] INFO : Using thread monitor-based data access locking (synchronization).
[2013-11-26 16:42:39,056] INFO : Removed 0 Volatile Trigger(s).
[2013-11-26 16:42:39,056] INFO : Removed 0 Volatile Job(s).
[2013-11-26 16:42:39,057] INFO : JobStoreTX initialized.
[2013-11-26 16:42:39,057] INFO : Scheduler meta-data: Quartz Scheduler (v1.8.4) 'flexraid' with instanceId '1'
  Scheduler class: 'org.quartz.core.QuartzScheduler' - running locally.
  NOT STARTED.
  Currently in standby mode.
  Number of jobs executed: 0
  Using thread pool 'org.quartz.simpl.SimpleThreadPool' - with 10 threads.
  Using job-store 'org.quartz.impl.jdbcjobstore.JobStoreTX' - which supports persistence. and is not clustered.

[2013-11-26 16:42:39,057] INFO : Quartz scheduler 'flexraid' initialized from default resource file in Quartz package: 'quartz.properties'
[2013-11-26 16:42:39,057] INFO : Quartz scheduler version: 1.8.4
[2013-11-26 16:42:39,066] INFO : Freed 0 triggers from 'acquired' / 'blocked' state.
[2013-11-26 16:42:39,067] INFO : Recovering 0 jobs that were in-progress at the time of the last shut-down.
[2013-11-26 16:42:39,067] INFO : Recovery complete.
[2013-11-26 16:42:39,067] INFO : Removed 0 'complete' triggers.
[2013-11-26 16:42:39,067] INFO : Removed 0 stale fired job entries.
[2013-11-26 16:42:39,068] INFO : Scheduler flexraid_$_1 started.
[2013-11-26 16:42:39,070] INFO : jetty-7.x.y-SNAPSHOT
[2013-11-26 16:42:39,074] INFO : started o.e.j.s.ServletContextHandler{/,null}
[2013-11-26 16:42:39,074] TRACE: keepalive=true
[2013-11-26 16:42:39,074] TRACE: keepalive=true
[2013-11-26 16:42:40,080] TRACE: Executing: smart
[2013-11-26 16:42:40,081] TRACE: => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2013-11-26 16:42:42,239] INFO : Started SocketConnector@0.0.0.0:8080 STARTING
[2013-11-26 16:43:08,858] INFO : Shutting down Quartz...
[2013-11-26 16:43:08,858] INFO : Scheduler flexraid_$_1 shutting down.
[2013-11-26 16:43:08,858] INFO : Scheduler flexraid_$_1 paused.
[2013-11-26 16:43:08,859] INFO : Scheduler flexraid_$_1 shutdown complete.
[2013-11-26 16:43:39,061] INFO : Setting core service port to 9595
[2013-11-26 16:43:39,061] INFO : Setting Http port to 8080
[2013-11-26 16:43:39,061] INFO : Https port not set. Https requests will not be serviced...
[2013-11-26 16:43:39,063] INFO : Starting FlexRAID...
[2013-11-26 16:43:39,063] INFO : FlexRAID 2.0u12 final [Snapshot 1.4 stable / Storage Pool 1.0 stable / Real-Time 1.0 experimental]
[2013-11-26 16:43:39,065] INFO : Started: 26. November 2013 16:43:39 MEZ
[2013-11-26 16:43:39,080] INFO : Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
[2013-11-26 16:43:39,080] INFO : Quartz Scheduler v.1.8.4 created.
[2013-11-26 16:43:39,080] INFO : Registering Quartz shutdown hook.
[2013-11-26 16:43:39,080] INFO : Using thread monitor-based data access locking (synchronization).
[2013-11-26 16:43:39,089] INFO : Removed 0 Volatile Trigger(s).
[2013-11-26 16:43:39,089] INFO : Removed 0 Volatile Job(s).
[2013-11-26 16:43:39,090] INFO : JobStoreTX initialized.
[2013-11-26 16:43:39,090] INFO : Scheduler meta-data: Quartz Scheduler (v1.8.4) 'flexraid' with instanceId '1'
  Scheduler class: 'org.quartz.core.QuartzScheduler' - running locally.
  NOT STARTED.
  Currently in standby mode.
  Number of jobs executed: 0
  Using thread pool 'org.quartz.simpl.SimpleThreadPool' - with 10 threads.
  Using job-store 'org.quartz.impl.jdbcjobstore.JobStoreTX' - which supports persistence. and is not clustered.

[2013-11-26 16:43:39,090] INFO : Quartz scheduler 'flexraid' initialized from default resource file in Quartz package: 'quartz.properties'
[2013-11-26 16:43:39,090] INFO : Quartz scheduler version: 1.8.4
[2013-11-26 16:43:39,100] INFO : Freed 0 triggers from 'acquired' / 'blocked' state.
[2013-11-26 16:43:39,103] INFO : Recovering 0 jobs that were in-progress at the time of the last shut-down.
[2013-11-26 16:43:39,103] INFO : Recovery complete.
[2013-11-26 16:43:39,103] INFO : Removed 0 'complete' triggers.
[2013-11-26 16:43:39,103] INFO : Removed 0 stale fired job entries.
[2013-11-26 16:43:39,104] INFO : Scheduler flexraid_$_1 started.
[2013-11-26 16:43:39,107] INFO : jetty-7.x.y-SNAPSHOT
[2013-11-26 16:43:39,113] INFO : started o.e.j.s.ServletContextHandler{/,null}
[2013-11-26 16:43:39,113] TRACE: keepalive=true
[2013-11-26 16:43:39,113] TRACE: keepalive=true
[2013-11-26 16:43:40,120] TRACE: Executing: smart
[2013-11-26 16:43:40,120] TRACE: => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2013-11-26 16:43:42,288] INFO : Started SocketConnector@0.0.0.0:8080 STARTING
[2013-11-26 16:43:43,565] INFO : Shutting down Quartz...
[2013-11-26 16:43:43,565] INFO : Scheduler flexraid_$_1 shutting down.
[2013-11-26 16:43:43,565] INFO : Scheduler flexraid_$_1 paused.
[2013-11-26 16:43:43,565] INFO : Scheduler flexraid_$_1 shutdown complete.
[2013-11-26 16:44:09,062] INFO : Setting core service port to 9595
[2013-11-26 16:44:09,062] INFO : Setting Http port to 8080
[2013-11-26 16:44:09,062] INFO : Https port not set. Https requests will not be serviced...
[2013-11-26 16:44:09,064] INFO : Starting FlexRAID...
[2013-11-26 16:44:09,064] INFO : FlexRAID 2.0u12 final [Snapshot 1.4 stable / Storage Pool 1.0 stable / Real-Time 1.0 experimental]
[2013-11-26 16:44:09,066] INFO : Started: 26. November 2013 16:44:09 MEZ
[2013-11-26 16:44:09,079] INFO : Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
[2013-11-26 16:44:09,079] INFO : Quartz Scheduler v.1.8.4 created.
[2013-11-26 16:44:09,079] INFO : Registering Quartz shutdown hook.
[2013-11-26 16:44:09,079] INFO : Using thread monitor-based data access locking (synchronization).
[2013-11-26 16:44:09,085] INFO : Removed 0 Volatile Trigger(s).
[2013-11-26 16:44:09,085] INFO : Removed 0 Volatile Job(s).
[2013-11-26 16:44:09,086] INFO : JobStoreTX initialized.
[2013-11-26 16:44:09,086] INFO : Scheduler meta-data: Quartz Scheduler (v1.8.4) 'flexraid' with instanceId '1'
  Scheduler class: 'org.quartz.core.QuartzScheduler' - running locally.
  NOT STARTED.
  Currently in standby mode.
  Number of jobs executed: 0
  Using thread pool 'org.quartz.simpl.SimpleThreadPool' - with 10 threads.
  Using job-store 'org.quartz.impl.jdbcjobstore.JobStoreTX' - which supports persistence. and is not clustered.

[2013-11-26 16:44:09,086] INFO : Quartz scheduler 'flexraid' initialized from default resource file in Quartz package: 'quartz.properties'
[2013-11-26 16:44:09,086] INFO : Quartz scheduler version: 1.8.4
[2013-11-26 16:44:09,093] INFO : Freed 0 triggers from 'acquired' / 'blocked' state.
[2013-11-26 16:44:09,094] INFO : Recovering 0 jobs that were in-progress at the time of the last shut-down.
[2013-11-26 16:44:09,094] INFO : Recovery complete.
[2013-11-26 16:44:09,094] INFO : Removed 0 'complete' triggers.
[2013-11-26 16:44:09,094] INFO : Removed 0 stale fired job entries.
[2013-11-26 16:44:09,094] INFO : Scheduler flexraid_$_1 started.
[2013-11-26 16:44:09,097] INFO : jetty-7.x.y-SNAPSHOT
[2013-11-26 16:44:09,102] INFO : started o.e.j.s.ServletContextHandler{/,null}
[2013-11-26 16:44:09,102] TRACE: keepalive=true
[2013-11-26 16:44:09,102] TRACE: keepalive=true
[2013-11-26 16:44:10,108] TRACE: Executing: smart
[2013-11-26 16:44:10,108] TRACE: => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2013-11-26 16:44:12,265] INFO : Started SocketConnector@0.0.0.0:8080 STARTING
[2013-11-26 16:44:38,826] INFO : Shutting down Quartz...
[2013-11-26 16:44:38,827] INFO : Scheduler flexraid_$_1 shutting down.
[2013-11-26 16:44:38,827] INFO : Scheduler flexraid_$_1 paused.
[2013-11-26 16:44:38,827] INFO : Scheduler flexraid_$_1 shutdown complete.
[2013-11-26 16:45:09,089] INFO : Setting core service port to 9595
[2013-11-26 16:45:09,089] INFO : Setting Http port to 8080
[2013-11-26 16:45:09,089] INFO : Https port not set. Https requests will not be serviced...
[2013-11-26 16:45:09,091] INFO : Starting FlexRAID...
[2013-11-26 16:45:09,091] INFO : FlexRAID 2.0u12 final [Snapshot 1.4 stable / Storage Pool 1.0 stable / Real-Time 1.0 experimental]
[2013-11-26 16:45:09,093] INFO : Started: 26. November 2013 16:45:09 MEZ
[2013-11-26 16:45:09,105] INFO : Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
[2013-11-26 16:45:09,105] INFO : Quartz Scheduler v.1.8.4 created.
[2013-11-26 16:45:09,105] INFO : Registering Quartz shutdown hook.
[2013-11-26 16:45:09,106] INFO : Using thread monitor-based data access locking (synchronization).
[2013-11-26 16:45:09,111] INFO : Removed 0 Volatile Trigger(s).
[2013-11-26 16:45:09,111] INFO : Removed 0 Volatile Job(s).
[2013-11-26 16:45:09,111] INFO : JobStoreTX initialized.
[2013-11-26 16:45:09,111] INFO : Scheduler meta-data: Quartz Scheduler (v1.8.4) 'flexraid' with instanceId '1'
  Scheduler class: 'org.quartz.core.QuartzScheduler' - running locally.
  NOT STARTED.
  Currently in standby mode.
  Number of jobs executed: 0
  Using thread pool 'org.quartz.simpl.SimpleThreadPool' - with 10 threads.
  Using job-store 'org.quartz.impl.jdbcjobstore.JobStoreTX' - which supports persistence. and is not clustered.

[2013-11-26 16:45:09,111] INFO : Quartz scheduler 'flexraid' initialized from default resource file in Quartz package: 'quartz.properties'
[2013-11-26 16:45:09,111] INFO : Quartz scheduler version: 1.8.4
[2013-11-26 16:45:09,118] INFO : Freed 0 triggers from 'acquired' / 'blocked' state.
[2013-11-26 16:45:09,119] INFO : Recovering 0 jobs that were in-progress at the time of the last shut-down.
[2013-11-26 16:45:09,119] INFO : Recovery complete.
[2013-11-26 16:45:09,120] INFO : Removed 0 'complete' triggers.
[2013-11-26 16:45:09,120] INFO : Removed 0 stale fired job entries.
[2013-11-26 16:45:09,121] INFO : Scheduler flexraid_$_1 started.
[2013-11-26 16:45:09,124] INFO : jetty-7.x.y-SNAPSHOT
[2013-11-26 16:45:09,128] INFO : started o.e.j.s.ServletContextHandler{/,null}
[2013-11-26 16:45:09,128] TRACE: keepalive=true
[2013-11-26 16:45:09,128] TRACE: keepalive=true
[2013-11-26 16:45:10,133] TRACE: Executing: smart
[2013-11-26 16:45:10,133] TRACE: => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2013-11-26 16:45:12,296] INFO : Started SocketConnector@0.0.0.0:8080 STARTING

 :o

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #70 on: November 26, 2013, 10:19:34 am »
There is really no sense in posting incomplete logs. You really need to stop doing that and it only wastes the time of those reading your posts with the intent of helping you.

But good that you were able to re-organize so many millions files.  :o

Offline wax7

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +0/-0
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #71 on: November 26, 2013, 12:29:16 pm »
that was a complete log of the error of re-starting and crashing but i doent know why now.... and it does it right after reboot now even without Browser....

the other log wasnt helpfull too  :( sorry that i doesnt saved quick....  now i try to get FlexRAID somehow working again.... but with no clou why its now not working, i try to reinstall it. The Last releasy seems not good stable...  :/

...skipping becorse of .... argh  wath was it...  below new file delay....something.... but only a page full the outofmemory again like always...

I send a log the i get this thing working again. ( and that on a clean installation *g*)

EDIT: Reinstall and deleting javacache+temp dien't worked... now going sleep, maybe i have tomorrow a clou waths going on...

Code: [Select]
mos-r@ubuntu:/var/lib/flexraid$ sudo ./FlexRAID
FlexRAID initialized successfully....
[db4o 8.0.249.16098   2013-11-27 07:55:34]
 '/root/FlexRAID-Config.db' closed by ShutdownHook.

if i pull out my DRU drive's it starts now.  ???
i mount my DRU drive'S and it crashes again?  WTF   :o

EDIT: i checked my Drives, all OK. Filesystem OK, too
Log doesn't look usefull....
« Last Edit: November 27, 2013, 03:17:07 am by wax7 »

Offline wax7

  • Jr. Member
  • **
  • Posts: 53
  • Karma: +0/-0
    • View Profile
Re: Need Restore help! INVALID_HANDLE_VALUE ERROR=2
« Reply #72 on: December 02, 2013, 03:59:55 am »
mmmh.. still crashing then mounting my DRU drives.
from one Problem to another....   :-\

Already uninstalled and Installed several times, but no Luck.
There are all the Install files?
I found the Installdirectory and the /Root/DB file.
Somethere else?