Author Topic: Save SMART Monitoring failed due to "Selected monitored attribute"  (Read 1359 times)

Offline vletroye

  • Hero Member
  • *****
  • Posts: 714
  • Karma: +7/-0
    • View Profile
Not a bug but just a feature a bit annoying...

There is not bulk process to enable SMART Monitoring on all drives.
So I do it one by one, as fast as possible:
- Change the selected device
- enable monitoring
- click save
- Change the selected device
- enable monitoring
- click save
- Change the selected device
- enable monitoring
- click save
- ...


After enabling Monitoring for the first drive, I selected a Monitor Attribute (to have a look).
This selected "Monitor Attributed" was not reset to blank when I moved to the next device...
And unfortunately, this attribute didn't exist for all my disks (E.g.: for SSD).

I didn't notice immediately, but this prevented me to "Save" the option "Monitor this drive"...
It's only later, when checking all my changes one by one, that I noticed the option was not ticked for such disks :-\

If this field may not be cleaned when navigating from a device to another, it should not be "valid" when "saving" changes in the settings...

« Last Edit: August 17, 2014, 05:35:24 pm by vletroye »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Save SMART Monitoring failed due to "Selected monitored attribute"
« Reply #1 on: August 17, 2014, 05:37:49 pm »
Fixed the field reset issue.

The build SMART setting should go as a feature request. So, will move the thread there.

Offline vletroye

  • Hero Member
  • *****
  • Posts: 714
  • Karma: +7/-0
    • View Profile
Re: Save SMART Monitoring failed due to "Selected monitored attribute"
« Reply #2 on: August 17, 2014, 05:39:01 pm »
Ok. And thx for the fix ;)