Author Topic: Can't start NZFS Web Client  (Read 488 times)

Offline mcao

  • Newbie
  • *
  • Posts: 16
  • Karma: +0/-0
    • View Profile
Can't start NZFS Web Client
« on: March 16, 2016, 03:00:06 am »
 All of a sudden my NZFS web client service won't start. I checked the NZFSWebUI.log file and saw this error:

Code: [Select]
[2016-03-16 00:59:11,395] INFO  start(56) - Setting Http port to 8080
[2016-03-16 00:59:11,397] INFO  start(56) - Https port not set. Https requests will not be serviced...
[2016-03-16 00:59:11,469] ERROR start(41) -
Version=2.1.beta15 , Build=270, Date=09/10/2013 12:55:17, Thread=main
Message:While creating Layer4 instance of org.neodatis.odb.core.layers.layer4.plugin.jdbm.NeoDatisJdbmPlugin :
Version=2.1.beta15 , Build=270, Date=09/10/2013 12:55:17, Thread=main
Message:Error while create persistent hashmap
StackTrace:
StackTrace:
org.neodatis.odb.NeoDatisRuntimeException:
Version=2.1.beta15 , Build=270, Date=09/10/2013 12:55:17, Thread=main
Message:While creating Layer4 instance of org.neodatis.odb.core.layers.layer4.plugin.jdbm.NeoDatisJdbmPlugin :
Version=2.1.beta15 , Build=270, Date=09/10/2013 12:55:17, Thread=main
Message:Error while create persistent hashmap
StackTrace:
StackTrace:
at org.neodatis.odb.core.session.SessionEngineImpl.initLayer4(SessionEngineImpl.java:190)
at org.neodatis.odb.core.session.SessionEngineImpl.<init>(SessionEngineImpl.java:115)
at org.neodatis.odb.core.session.SessionImpl.buildSessionEngine(SessionImpl.java:123)
at org.neodatis.odb.core.session.SessionImpl.init(SessionImpl.java:110)
at org.neodatis.odb.core.session.SessionImpl.<init>(SessionImpl.java:84)
at org.neodatis.odb.core.CoreProviderImpl.getLocalSession(CoreProviderImpl.java:172)
at org.neodatis.odb.main.LocalODB.<init>(LocalODB.java:46)
at org.neodatis.odb.main.LocalODB.getInstance(LocalODB.java:35)
at org.neodatis.odb.NeoDatis.open(NeoDatis.java:104)
at com.tchegbe.lib.ext.neodatis.NeoDatisDBFactory.initEmbedded(NeoDatisDBFactory.java:111)
at com.tchegbe.lib.ext.neodatis.NeoDatisDBFactory.getInstance(NeoDatisDBFactory.java:77)
at com.tchegbe.nzfs.ui.server.db.PersistenceService.getInstance(PersistenceService.java:86)
at com.tchegbe.nzfs.ui.server.main.Main.start(Main.java:56)
at com.tchegbe.nzfs.ui.server.main.NZFSWinService.run(NZFSWinService.java:41)
Caused by: org.neodatis.odb.NeoDatisRuntimeException:
Version=2.1.beta15 , Build=270, Date=09/10/2013 12:55:17, Thread=main
Message:Error while create persistent hashmap
StackTrace:
at org.neodatis.odb.core.layers.layer4.plugin.jdbm.NeoDatisJdbmPlugin.open(NeoDatisJdbmPlugin.java:130)
at org.neodatis.odb.core.session.SessionEngineImpl.initLayer4(SessionEngineImpl.java:181)
... 13 more
Caused by: java.io.StreamCorruptedException: invalid stream header: 00000000
at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.class)
at java.io.ObjectInputStream.<init>(ObjectInputStream.class)
at jdbm.recman.TransactionManager.recover(Unknown Source)
at jdbm.recman.TransactionManager.<init>(Unknown Source)
at jdbm.recman.RecordFile.<init>(Unknown Source)
at jdbm.recman.BaseRecordManager.<init>(Unknown Source)
at jdbm.recman.Provider.createRecordManager(Unknown Source)
at jdbm.RecordManagerFactory.createRecordManager(Unknown Source)
at org.neodatis.odb.core.layers.layer4.plugin.jdbm.PHashMapBTree.<init>(Unknown Source)
at org.neodatis.odb.core.layers.layer4.plugin.jdbm.NeoDatisJdbmPlugin.open(NeoDatisJdbmPlugin.java:128)
... 14 more

System is Windows 7 x64, using the latest TRAID version.
« Last Edit: March 16, 2016, 03:01:57 am by mcao »

Offline d2dyno

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Can't start NZFS Web Client
« Reply #1 on: October 07, 2016, 04:54:36 pm »
I'm having the exact same issue. Were you able to figure it out?

Offline d2dyno

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Re: Can't start NZFS Web Client
« Reply #2 on: October 07, 2016, 06:01:33 pm »
I fixed this by removing all .db files (I think the .db.lg file was the culprit), starting the web service. Verified it worked, then stopped service, copied known good backup of db, started again and all is well!

Offline thecig

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: Can't start NZFS Web Client
« Reply #3 on: March 18, 2017, 08:38:01 pm »
I fixed this by removing all .db files (I think the .db.lg file was the culprit), starting the web service. Verified it worked, then stopped service, copied known good backup of db, started again and all is well!

You are a star!
This fixed my issue.
I just moved my db.lg file to another folder, rebooted and all is well.

Thanks.