Author Topic: WHS 2011 server shares won't stick no matter what  (Read 745 times)

Offline ktide1

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
WHS 2011 server shares won't stick no matter what
« on: June 06, 2016, 10:30:24 am »
I run FlexRaid on a WHS 2011 server.  WHS 2011 runs as a virtual machine under Hyper-V.  I've been using RaidF 2.0 for a long time for snapshot RAID and a storage pool (using Cruise Control) with server shares set up (some mirror default WHS 2011 shares, some are added by me).  All shares are mirrored in the Dashboard per the "old" instructions and have worked with no issues (other than indexing).

Finally took the time and upgraded to 2.1 the last couple of days, intending to change to Expert mode at the time of upgrade.  So stopped the old pool, stopped the service, uninstalled the old version, deleted all the installation folders, and basically started clean again and installed 2.1 version.  I mounted the storage drives in folders this time and created a snapshot array, Tx engine using Expert mode.  So far so good, no problems.  Next, I created the storage pool, with no issues setting it up initially, so I'm thinking I'm in good shape here.

So next I try to set up the server shares and the "fun" begins.  I know with the new version that the entire pool must be shared, I can live with that part.  So I set up the share through the normal Windows dialog, sharing the entire pooled drive.  Next I went to the Server Shares section in the web UI and clicked the "Backup Shares" button per the "new way" of setting up server shares.  However, when I reboot the shares won't "stick" no matter what I do.  I'm not talking about showing in the Dashboard (although I'd like that too if possible).  I'm saying after a reboot, the pooled drive shows "not shared" in Windows Explorer and I cannot access the pool over my LAN.

I've checked and re-checked permissions numerous times, fiddled with mirroring the shares in the Dashboard (both before and after setting up shares in Windows Explorer), and done just about everything except stand on my head to make this work and no matter what I do I lose the shares after reboot - every time.

Finally, I gave up and set up a Cruise Control configuration (setting up shares the "old way" with old server shares web UI enabled) just so I could have access to the share over the LAN.  I would really like to run Expert mode but I cannot seem to get over this hump no matter what I do.  I've searched and read numerous forum posts for similar issues and the only response seems to be to use the server shares backup UI and it should work.  I can't make it happen and I have a very simple set up.

HELP!  What am I missing?  Thanks in advance.