Author Topic: Scheduler strangeness  (Read 1382 times)

Offline Reddwarfusa

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +2/-0
    • View Profile
Scheduler strangeness
« on: February 07, 2017, 09:18:33 am »
A buddy is having a strange type of behavior when setting up scheduler.  He can add a job and its gets scheduled.  However when it runs it says "BLOCKED" and then gives a secondary cryptic entry in the scheduler tab.  It does not look like it fires off the activity.  I've helped him to load from warm (keeping all the logs in place) also completely loaded from cold (removing logs etc) and no change.  I make sure I install the host and client as administrators but no change.  This is running on a Server 2012 box.  Any ideas?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Scheduler strangeness
« Reply #1 on: February 07, 2017, 11:42:47 am »

Offline Reddwarfusa

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +2/-0
    • View Profile
Re: Scheduler strangeness
« Reply #2 on: February 08, 2017, 10:37:53 am »
Yes I ran the reset utility and it cleared out the scheduler, I readded the events and tried to manually run, I still get blocked showing up and the event doesn't run.  Any other ideas?  I need to ensure the array gets veryified and syncs regularly.
Thanks

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Scheduler strangeness
« Reply #3 on: February 08, 2017, 04:17:22 pm »
Hum... can't think of anything else.
Try a different schedule pattern.

Offline Reddwarfusa

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +2/-0
    • View Profile
Re: Scheduler strangeness
« Reply #4 on: February 08, 2017, 04:28:14 pm »
Would any windows patches cause the behavior?  Something has changed.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Scheduler strangeness
« Reply #5 on: February 09, 2017, 09:09:24 am »
Would any windows patches cause the behavior?  Something has changed.
Short of deleting the DB and letting it be re-created anew, I truly can't think of the true cause of that issue.

Offline Reddwarfusa

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +2/-0
    • View Profile
Re: Scheduler strangeness
« Reply #6 on: April 11, 2018, 12:05:34 pm »
In case this is useful, we think we found a root cause.  For some reason is the PPU drives (running two of them) are differing sizes the scheduler will not run properly.  We changed noting except the parity drive sizes to match and then everything worked normally.  could this be some sort of bug?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Scheduler strangeness
« Reply #7 on: April 16, 2018, 10:00:52 am »
The sizes of the PPU disks certainly have no effect on the scheduler.
Certainly a coincidence.

Offline Reddwarfusa

  • Jr. Member
  • **
  • Posts: 86
  • Karma: +2/-0
    • View Profile
Re: Scheduler strangeness
« Reply #8 on: April 16, 2018, 10:55:15 am »
I would agreed, except it happened on two separate systems with no relation to each other.  Neither of us could get scheduler to work, we both had differing ppu sizes (i had changed one of mine) and scheduler would fail.  We tried the experiment on each system and low and behold the scheduler ran.  Might be a coincidence but something very strange, and never had a problem since.