Author Topic: Cannot Create Files/Folders in New Pool  (Read 126 times)

Offline moredrives

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Cannot Create Files/Folders in New Pool
« on: May 14, 2017, 08:15:13 pm »
Greetings,

I am evaluating FlexRAID Storage Pooling -- I don't plan to use FlexRAID's Data Protection (RAID-F).

I have several network drives (in this case, NAS devices) which I want to pool together, possibly also with a few local hard drives (though I'd want those to be last in the list, such that the NAS locations get filled first). The data that I will be storing will all be a massive CrashPlan archive (which is made of up of lots their proprietary, encrypted files). I have CrashPlan installed at this location, and I'll be backing up to this storage pool via CrashPlan's "backup other computers to this computer" feature.

For testing purposes, the following are my Unique Volumes:
\\NAS\backup\flexRAIDtest
\\A_WINDOWS_COMPUTER\A_SHARED_FOLDER\flexRAIDtest
F:\flexRAIDtest

I've finally been able to get my storage pool created and started, but I'm running into mount errors and I'm unable to add any data to the pool.

I've run UserMode.cmd (as Admin), and rebooted (I may have rebooted an additional time or two since then -- I can't remember at the moment).

I followed this post ( http://forum.flexraid.com/index.php/topic,5113.msg30846.html#msg30846 ) and mounted the pool as Fixed instead of Removable (though I'd prefer to use Removable if possible).

I've also followed the instructions ( http://wiki.flexraid.com/2011/06/09/running-flexraid-under-a-different-user-account-for-network-access/ ) for running FlexRAID as a particular user so that it should have network drive access.

Using this post ( http://forum.flexraid.com/index.php/topic,2096.msg15790.html#msg15790 ) which mentions one of my errors (a Catastrophic failure 0x8000FFFF code) I have looked for the folder C:\FlexRAID_Managed_Pool, but it does not appear to exist on my system.

Here's my FlexRAID.log:
Code: [Select]
[2017-05-11 22:36:52,713] INFO : Setting core service port to 9595
[2017-05-11 22:36:52,713] INFO : Setting Http port to 8080
[2017-05-11 22:36:52,713] INFO : Https port not set. Https requests will not be serviced...
[2017-05-11 22:36:52,714] INFO : Starting FlexRAID...
[2017-05-11 22:36:52,714] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.11.01]
[2017-05-11 22:36:52,714] INFO : Started: May 11, 2017 10:36:52 PM EDT
[2017-05-11 22:37:07,995] INFO : F3
[2017-05-11 22:39:48,695] INFO : Service stopping...
[2017-05-11 22:39:48,696] INFO : Stopping views...
[2017-05-11 22:39:48,696] INFO : Stopping scheduler...
[2017-05-11 22:39:48,696] INFO : Stopping web server...
[2017-05-11 22:39:48,748] INFO : Stopping socket server...
[2017-05-11 22:39:48,779] INFO : Shutting down at: 5/11/17 10:39 PM
[2017-05-11 22:39:48,779] INFO : Closing all client connections...
[2017-05-11 22:39:52,299] INFO : Setting core service port to 9595
[2017-05-11 22:39:52,299] INFO : Setting Http port to 8080
[2017-05-11 22:39:52,299] INFO : Https port not set. Https requests will not be serviced...
[2017-05-11 22:39:52,300] INFO : Starting FlexRAID...
[2017-05-11 22:39:52,300] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.11.01]
[2017-05-11 22:39:52,301] INFO : Started: May 11, 2017 10:39:52 PM EDT
[2017-05-11 22:40:06,104] INFO : F3
[2017-05-11 22:44:26,399] INFO : Saving Storage Pool...
[2017-05-11 22:55:33,610] INFO : Building Auto View Registry...
[2017-05-11 22:55:33,619] INFO : Loading View options...
[2017-05-11 22:55:38,620] INFO : Using Auto-View definition...
[2017-05-11 23:00:02,707] INFO : Initiating FlexRAID Storage Pool...
[2017-05-11 23:00:02,770] INFO : Host OS = Microsoft Windows [Version 10.0.14393]
[2017-05-11 23:00:02,770] INFO : Building View Registry...
[2017-05-11 23:00:02,771] INFO : Building Auto View Registry...
[2017-05-11 23:00:02,790] INFO : Loading View options...
[2017-05-11 23:00:07,670] INFO : Using Auto-View definition...
[2017-05-11 23:00:07,670] INFO : Building View Handler...
[2017-05-11 23:00:07,776] INFO : Mounting Storage Pool drive...
[2017-05-11 23:06:57,453] INFO : Unmounting View...
[2017-05-11 23:06:57,471] INFO : Unmounting View complete...
[2017-05-11 23:07:09,628] INFO : Initiating FlexRAID Storage Pool...
[2017-05-11 23:07:09,705] INFO : Host OS = Microsoft Windows [Version 10.0.14393]
[2017-05-11 23:07:09,705] INFO : Building View Registry...
[2017-05-11 23:07:09,705] INFO : Building Auto View Registry...
[2017-05-11 23:07:09,763] INFO : Loading View options...
[2017-05-11 23:07:14,584] INFO : Using Auto-View definition...
[2017-05-11 23:07:14,584] INFO : Building View Handler...
[2017-05-11 23:07:14,800] INFO : Mounting Storage Pool drive...
[2017-05-11 23:09:00,263] INFO : Service stopping...
[2017-05-11 23:09:00,264] INFO : Stopping views...
[2017-05-11 23:09:00,514] INFO : Unmounting View...
[2017-05-11 23:09:00,514] INFO : Unmounting View complete...
[2017-05-11 23:09:00,516] INFO : Stopping scheduler...
[2017-05-11 23:09:00,706] INFO : Stopping web server...
[2017-05-11 23:09:02,298] INFO : Stopping socket server...
[2017-05-11 23:09:03,675] INFO : Shutting down at: 5/11/17 11:09 PM
[2017-05-11 23:09:03,675] INFO : Closing all client connections...
[2017-05-11 23:09:03,677] INFO : Exiting all processes...
[2017-05-11 23:09:13,952] INFO : Setting core service port to 9595
[2017-05-11 23:09:13,953] INFO : Setting Http port to 8080
[2017-05-11 23:09:13,953] INFO : Https port not set. Https requests will not be serviced...
[2017-05-11 23:09:13,954] INFO : Starting FlexRAID...
[2017-05-11 23:09:13,954] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.11.01]
[2017-05-11 23:09:13,954] INFO : Started: May 11, 2017 11:09:13 PM EDT
[2017-05-11 23:09:28,651] INFO : F3
[2017-05-11 23:10:51,682] INFO : Initiating FlexRAID Storage Pool...
[2017-05-11 23:10:51,770] INFO : Host OS = Microsoft Windows [Version 10.0.14393]
[2017-05-11 23:10:51,771] INFO : Building View Registry...
[2017-05-11 23:10:51,772] INFO : Building Auto View Registry...
[2017-05-11 23:10:51,818] INFO : Loading View options...
[2017-05-11 23:10:56,682] INFO : Using Auto-View definition...
[2017-05-11 23:10:56,682] INFO : Building View Handler...
[2017-05-11 23:10:56,754] INFO : Mounting Storage Pool drive...
[2017-05-12 10:51:09,099] INFO : Service stopping...
[2017-05-12 10:51:09,100] INFO : Stopping views...
[2017-05-12 10:51:09,100] INFO : Unmounting View...
[2017-05-12 10:51:09,101] INFO : Unmounting View complete...
[2017-05-12 10:51:09,102] INFO : Stopping scheduler...
[2017-05-12 10:51:09,102] INFO : Stopping web server...
[2017-05-12 10:51:09,154] INFO : Stopping socket server...
[2017-05-12 10:51:09,701] INFO : Shutting down at: 5/12/17 10:51 AM
[2017-05-12 10:51:09,701] INFO : Closing all client connections...
[2017-05-12 10:51:09,701] INFO : Exiting all processes...
[2017-05-12 10:51:11,029] ERROR: Connection refused: connect
java.net.ConnectException: Connection refused: connect
at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at com.tchegbe.lib.b.a.b.a(Unknown Source)
at com.tchegbe.lib.b.a.e.a(Unknown Source)
at com.tchegbe.lib.b.a.g.a(Unknown Source)
at com.tchegbe.lib.common.i.d.b(Unknown Source)
at com.tchegbe.lib.common.i.a.run(Unknown Source)
[2017-05-12 10:51:11,732] ERROR: Connection refused: connect
java.net.ConnectException: Connection refused: connect
at java.net.DualStackPlainSocketImpl.waitForConnect(Native Method)
at java.net.DualStackPlainSocketImpl.socketConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl.doConnect(Unknown Source)
at java.net.AbstractPlainSocketImpl.connectToAddress(Unknown Source)
at java.net.AbstractPlainSocketImpl.connect(Unknown Source)
at java.net.PlainSocketImpl.connect(Unknown Source)
at java.net.SocksSocketImpl.connect(Unknown Source)
at java.net.Socket.connect(Unknown Source)
at com.tchegbe.lib.b.a.b.a(Unknown Source)
at com.tchegbe.lib.b.a.e.a(Unknown Source)
at com.tchegbe.lib.b.a.g.a(Unknown Source)
at com.tchegbe.lib.common.i.d.a(Unknown Source)
at com.tchegbe.lib.common.i.a.<unknown>(Unknown Source)
at com.tchegbe.lib.common.i.a.<unknown>(Unknown Source)
at com.tchegbe.lib.common.i.a.<unknown>(Unknown Source)
at com.tchegbe.lib.io.a.h.run(Unknown Source)
[2017-05-12 15:03:43,312] INFO : Setting core service port to 9595
[2017-05-12 15:03:43,312] INFO : Setting Http port to 8080
[2017-05-12 15:03:43,312] INFO : Https port not set. Https requests will not be serviced...
[2017-05-12 15:03:43,695] INFO : Starting FlexRAID...
[2017-05-12 15:03:43,764] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.11.01]
[2017-05-12 15:03:43,783] INFO : Started: May 12, 2017 3:03:43 PM EDT
[2017-05-12 15:04:05,940] INFO : F3
[2017-05-12 15:05:30,266] INFO : Initiating FlexRAID Storage Pool...
[2017-05-12 15:05:30,356] INFO : Host OS = Microsoft Windows [Version 10.0.14393]
[2017-05-12 15:05:30,357] INFO : Building View Registry...
[2017-05-12 15:05:30,357] INFO : Building Auto View Registry...
[2017-05-12 15:05:30,369] INFO : Loading View options...
[2017-05-12 15:05:35,444] INFO : Using Auto-View definition...
[2017-05-12 15:05:35,444] INFO : Building View Handler...
[2017-05-12 15:05:35,775] INFO : Mounting Storage Pool drive...
[2017-05-12 15:10:35,093] INFO : Unmounting View...
[2017-05-12 15:10:35,093] INFO : Unmounting View complete...
[2017-05-12 15:11:46,165] INFO : Initiating FlexRAID Storage Pool...
[2017-05-12 15:11:46,248] INFO : Host OS = Microsoft Windows [Version 10.0.14393]
[2017-05-12 15:11:46,248] INFO : Building View Registry...
[2017-05-12 15:11:46,249] INFO : Building Auto View Registry...
[2017-05-12 15:11:46,257] INFO : Loading View options...
[2017-05-12 15:11:51,649] INFO : Using Auto-View definition...
[2017-05-12 15:11:51,649] INFO : Building View Handler...
[2017-05-12 15:11:51,862] INFO : Mounting Storage Pool drive...
[2017-05-12 15:25:40,555] INFO : Unmounting View...
[2017-05-12 15:25:45,701] INFO : Unmounting View complete...
[2017-05-12 15:25:57,426] INFO : Initiating FlexRAID Storage Pool...
[2017-05-12 15:25:57,454] INFO : Host OS = Microsoft Windows [Version 10.0.14393]
[2017-05-12 15:25:57,454] INFO : Building View Registry...
[2017-05-12 15:25:57,455] INFO : Building Auto View Registry...
[2017-05-12 15:25:57,457] INFO : Loading View options...
[2017-05-12 15:25:57,722] INFO : Using Auto-View definition...
[2017-05-12 15:25:57,722] INFO : Building View Handler...
[2017-05-12 15:25:57,889] INFO : Mounting Storage Pool drive...
[2017-05-12 15:38:31,088] INFO : Unmounting View...
[2017-05-12 15:38:31,088] INFO : Unmounting View complete...
[2017-05-12 15:38:43,230] INFO : Initiating FlexRAID Storage Pool...
[2017-05-12 15:38:43,299] INFO : Host OS = Microsoft Windows [Version 10.0.14393]
[2017-05-12 15:38:43,299] INFO : Building View Registry...
[2017-05-12 15:38:43,299] INFO : Building Auto View Registry...
[2017-05-12 15:38:43,313] INFO : Loading View options...
[2017-05-12 15:38:48,364] INFO : Using Auto-View definition...
[2017-05-12 15:38:48,364] INFO : Building View Handler...
[2017-05-12 15:38:48,455] INFO : Mounting Storage Pool drive...

And my FlexRAID.sys.c1-1.log:
Code: [Select]
[2017-05-11 22:45:24.799045][7332][DLL_THREAD_DETACH] ID=7332
[2017-05-11 23:00:07.777976][14056]Build Timestamp [Nov  1 2015 04:04:22]
[2017-05-11 23:00:07.777976][14056]


--------------- Storage Pool Start ---------------
[2017-05-11 23:00:07.777976][14056][Mounting Storage Pool]
[2017-05-11 23:00:07.777976][14056][VM already acquired...]
[2017-05-11 23:00:07.777976][14056][Building options...]
[2017-05-11 23:01:49.756907][14056][mount] [Create New Storage Pool] ErrorCode=31 Message=Mount error! Code=87 Message=The parameter is incorrect.


[2017-05-11 23:06:57.470963][7532]Unmounting the storage pool
[2017-05-11 23:07:14.802055][3572]Build Timestamp [Nov  1 2015 04:04:22]
[2017-05-11 23:07:14.802055][3572]


--------------- Storage Pool Start ---------------
[2017-05-11 23:07:14.802056][3572][Mounting Storage Pool]
[2017-05-11 23:07:14.802056][3572][VM already acquired...]
[2017-05-11 23:07:14.802056][3572][Building options...]
[2017-05-11 23:08:29.081978][3572][mount] [Create New Storage Pool] ErrorCode=31 Message=Mount error! Code=87 Message=The parameter is incorrect.


[2017-05-11 23:09:00.515109][7748]Unmounting the storage pool
[2017-05-11 23:09:21.681657][11276][DLL_THREAD_ATTACH] ID=11276
[2017-05-11 23:10:56.755904][8916]Build Timestamp [Nov  1 2015 04:04:22]
[2017-05-11 23:10:56.755904][8916]


--------------- Storage Pool Start ---------------
[2017-05-11 23:10:56.755904][8916][Mounting Storage Pool]
[2017-05-11 23:10:56.755904][8916][VM already acquired...]
[2017-05-11 23:10:56.755904][8916][Building options...]
[2017-05-11 23:12:19.179300][8916][mount] [Create New Storage Pool] ErrorCode=31 Message=Mount error! Code=87 Message=The parameter is incorrect.


[2017-05-12 10:51:09.103052][14756]Unmounting the storage pool
[2017-05-12 15:03:55.240202][11756][DLL_THREAD_ATTACH] ID=11756
[2017-05-12 15:05:35.776975][10656]Build Timestamp [Nov  1 2015 04:04:22]
[2017-05-12 15:05:35.776975][10656]


--------------- Storage Pool Start ---------------
[2017-05-12 15:05:35.776975][10656][Mounting Storage Pool]
[2017-05-12 15:05:35.776976][10656][VM already acquired...]
[2017-05-12 15:05:35.776976][10656][Building options...]
[2017-05-12 15:06:50.463941][10656][mount] [Create New Storage Pool] ErrorCode=31 Message=Mount error! Code=87 Message=The parameter is incorrect.


[2017-05-12 15:10:35.096028][12752]Unmounting the storage pool
[2017-05-12 15:11:51.864265][14220]Build Timestamp [Nov  1 2015 04:04:22]
[2017-05-12 15:11:51.864265][14220]


--------------- Storage Pool Start ---------------
[2017-05-12 15:11:51.864265][14220][Mounting Storage Pool]
[2017-05-12 15:11:51.864265][14220][VM already acquired...]
[2017-05-12 15:11:51.864265][14220][Building options...]
[2017-05-12 15:13:11.154223][9852] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\System Volume Information -> DRU1\System Volume Information

[2017-05-12 15:15:09.299399][1696] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\New folder -> DRU1\New folder

[2017-05-12 15:16:22.194053][15208] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\New folder -> DRU1\New folder

[2017-05-12 15:16:23.695708][1696] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\New folder -> DRU1\New folder

[2017-05-12 15:16:29.338528][1696] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\New folder -> DRU1\New folder

[2017-05-12 15:23:58.656579][4832] [WARN]:[OnCreateFile] CreateFile: error=67, msg=Error code=67 - Message=Unknown error
\New Text Document.txt -> DRU1\New Text Document.txt

[2017-05-12 15:25:40.556246][13480]Unmounting the storage pool
[2017-05-12 15:25:55.538185][14220][Returning from pooling session...]
[2017-05-12 15:25:57.891353][12808]Build Timestamp [Nov  1 2015 04:04:22]
[2017-05-12 15:25:57.891353][12808]


--------------- Storage Pool Start ---------------
[2017-05-12 15:25:57.891354][12808][Mounting Storage Pool]
[2017-05-12 15:25:57.891354][12808][VM already acquired...]
[2017-05-12 15:25:57.891354][12808][Building options...]
[2017-05-12 15:27:17.166258][12808][mount] [Create New Storage Pool] ErrorCode=31 Message=Mount error! Code=87 Message=The parameter is incorrect.


[2017-05-12 15:38:31.091010][11644]Unmounting the storage pool
[2017-05-12 15:38:48.455913][7084]Build Timestamp [Nov  1 2015 04:04:22]
[2017-05-12 15:38:48.455913][7084]


--------------- Storage Pool Start ---------------
[2017-05-12 15:38:48.455913][7084][Mounting Storage Pool]
[2017-05-12 15:38:48.455913][7084][VM already acquired...]
[2017-05-12 15:38:48.455913][7084][Building options...]
[2017-05-12 15:40:26.926469][2732] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\New folder -> DRU1\New folder

[2017-05-12 19:15:54.900382][9784] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\New folder -> DRU1\New folder

[2017-05-14 21:09:42.367623][12152] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\New folder -> DRU1\New folder

[2017-05-14 21:10:16.514107][12152] [ERROR]:[OnCreateFile] CreateDirectory: error=67, msg=Error code=67 - Message=Unknown error
\New folder -> DRU1\New folder


Any help is appreciated! Currently FlexRAID Storage Pooling is unusable, but I'd like to give it a shot. I'm also evaluating Drive Bender, and have written another post soliciting opinions, experience, etc on FlexRAID Storage Pooling vs Drive Bender ( http://forum.flexraid.com/index.php/topic,49276.0.html ), which I'd also welcome feedback on.

Thanks much!
:)

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,303
  • Karma: +199/-15
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #1 on: May 15, 2017, 05:58:15 pm »
https://www.google.com/#q=windows+error+67

Make sure the FlexRAID service is running under a user that has proper permissions to all the shares you are trying to pool.

Offline moredrives

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #2 on: May 16, 2017, 06:49:18 am »
https://www.google.com/#q=windows+error+67

Make sure the FlexRAID service is running under a user that has proper permissions to all the shares you are trying to pool.
Thanks, but I've already done that.
I've also followed the instructions ( http://wiki.flexraid.com/2011/06/09/running-flexraid-under-a-different-user-account-for-network-access/ ) for running FlexRAID as a particular user so that it should have network drive access.
Other thoughts, suggestions?

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,303
  • Karma: +199/-15
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #3 on: May 16, 2017, 05:00:36 pm »
Check the permissions on the shares and those of the drives hosting the shares. The NTFS permissions on those drives might be restrictive as to block the share permissions.

Offline moredrives

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #4 on: May 16, 2017, 08:00:56 pm »
Check the permissions on the shares and those of the drives hosting the shares. The NTFS permissions on those drives might be restrictive as to block the share permissions.
That's a good idea!

The NAS subfolder has permissions of Everyone having Full Control. But I also tried giving explicit Full Control to the user that FlexRAID is logged in as.

A network folder (on another Windows machine) has Full Control for the same user that FlexRAID service is logged in as.

The local drive folder was actually lacking some permissions, so I explicitly added Full Control for the user that FlexRAID is logged in as.

I then Re-Started the Pool, but I'm still seeing the same issues, unfortunately.


Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,303
  • Karma: +199/-15
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #5 on: May 16, 2017, 10:39:53 pm »
Is this domain based or workgroup based networking?
Which OS on each of the shares?

Offline moredrives

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #6 on: May 17, 2017, 06:45:35 am »
Workgroup based.

\\NAS\backup\flexRAIDtest :: Netgear ReadyNAS NVX OS
\\A_WINDOWS_COMPUTER\A_SHARED_FOLDER\flexRAIDtest :: Windows 10 Pro
F:\flexRAIDtest :: Windows 10 Pro

The ReadyNAS access controls are foremost handled by which users are granted access to a given share, though one can also assign (I think) Windows permissions (if you have access to the share already). So the same user that FlexRAID is using has access to the share in question on the ReadyNAS (defined in the ReadyNAS's OS).

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,303
  • Karma: +199/-15
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #7 on: May 17, 2017, 07:03:19 am »
Which one is DRU1?

Workgroup sharing is more tricky. Operations that need file ownership will typically fail, which is what I think might be happening in your case.

Offline moredrives

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #8 on: May 17, 2017, 10:23:22 am »
This it the order they are in on the Run-Time Properties screen, Unique Volumes field:
\\NAS\backup\flexRAIDtest
F:\flexRAIDtest

Does that tell you what you need?

FYI: I decided to remove the middle one -- the Windows share -- just to reduce the variables we're dealing with. The above approximates what I'd ultimately be wanting to do, which is multiple NAS locations (each from a different ReadyNAS), followed by one or two local hard drives.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,303
  • Karma: +199/-15
    • View Profile
Re: Cannot Create Files/Folders in New Pool
« Reply #9 on: May 17, 2017, 01:17:51 pm »
Yeah, I would say create a pool with a single share first and make sure it works the way you wish before adding others.
Then focus of addressing the permission issues of each of the target shares.