Author Topic: High CPU usage flexRAID.exe on MS Server 2016, eventually stuck at 100%  (Read 604 times)

Offline monkeh

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Hi

I have a problem with Flexraid running on Windows server 2016 since yesterday, it has started consuming 25% of CPU and then increases quickly to 100% when writing to the pool, it has never done this before, the only thing that has changed on this server is Windows updates, the latest being for for Q1 2018 KB4057142 but this was installed on the 27/01.  This update does appear to contain some fixes for the Spector and Meltdown security issues. I have had issues with some Asus Motherboard utilities on another computer due to these  :(

I only used flexraid for the storage pooling now, so it has a relatively easy life and did not consume any CPU until this week.

It does not seem to generate any error messages, prior to me killing the process, is there any hidden debug options that can be enabled?
I was on FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.11.01]

But have just updated to the latest version, however this does not look to be a bugfix release and has not resolved the issue.


« Last Edit: February 13, 2018, 03:05:43 pm by monkeh »

Offline monkeh

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: High CPU usage flexRAID.exe on MS Server 2016, eventually stuck at 100%
« Reply #1 on: February 13, 2018, 05:42:42 pm »
OK, so I have removed the windows update and the problem has cleared, so it looks to be the a result of the Meltdown and Spector fixes.. But as Flexraid seems to be EOL I will have to move to a product like DriveBender

Offline kevin.r

  • Newbie
  • *
  • Posts: 33
  • Karma: +0/-0
    • View Profile
Re: High CPU usage flexRAID.exe on MS Server 2016, eventually stuck at 100%
« Reply #2 on: February 13, 2018, 09:59:34 pm »
OK, so I have removed the windows update and the problem has cleared, so it looks to be the a result of the Meltdown and Spector fixes.. But as Flexraid seems to be EOL I will have to move to a product like DriveBender

FlexRaid is not at EOL, if you've purchased a license you'll be upgraded to an umbrella application, FlexRaid One, that will serve the purpose of your original license and more...free of charge. (From what I've gathered...but I have no affiliation to FlexRaid, so read up on this thread: http://forum.flexraid.com/index.php/topic,49425.0.html)

Offline monkeh

  • Newbie
  • *
  • Posts: 6
  • Karma: +0/-0
    • View Profile
Re: High CPU usage flexRAID.exe on MS Server 2016, eventually stuck at 100%
« Reply #3 on: February 14, 2018, 02:41:32 am »
I only meant flexraid-f being EOL, as it hadn't had any updates for 3+ years

Thanks for that link I had not seen that post, but given the severity of the security issues with meltdown and spector I cant run this server without the security updates so will have to use something else for now  :-[

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: High CPU usage flexRAID.exe on MS Server 2016, eventually stuck at 100%
« Reply #4 on: February 17, 2018, 11:28:45 am »
I only meant flexraid-f being EOL, as it hadn't had any updates for 3+ years

Thanks for that link I had not seen that post, but given the severity of the security issues with meltdown and spector I cant run this server without the security updates so will have to use something else for now  :-[
Check the official site as a new build has been pushed out a couple of months back.
Try to subscribe to http://new.flexraid.com if you aren't getting new release notifications.