Author Topic: Can't access pooled storage on Linux  (Read 113 times)

Offline sergicles

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Can't access pooled storage on Linux
« on: July 08, 2018, 06:23:27 am »
Hi All

I've been using FlexRAID-f for a while. Today, I thought it's time to upgrade and rebuild the underlying server in general. I installed the software and noticed that pooled storage is not accessible by other users, other than root.

For example, this is what I see when I 'ls' the pool.

Code: [Select]
➜  /mnt pwd
/mnt
➜  /mnt whoami
nas
➜  /mnt ls -al
ls: cannot access 'data_pool': Permission denied
total 92
drwxr-xr-x  8 root root    4096 Jul  8 08:05 .
drwxr-xr-x 23 root root    4096 Jul  7 06:36 ..
d?????????  ? ?    ?          ?            ? data_pool

I am using Ubuntu 18.04 LTS and 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2017.11.21].
Currently on evaluation copy, until I get everything working.

Ultimately, I would like 'nas' user to be able to read and write to 'data_pool'. As a 'root' user everything works fine.

I also tried tinkering with '/opt/raidf/host/ext/mount-extra-params.txt' file and added 'allow_other'

Code: [Select]
*=-o allow_other,rw,nosuid,nodev
However, at this stage I am just throwing arrows in the dark here, any help would be fantastic.


Cheers

Offline sergicles

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Can't access pooled storage on Linux
« Reply #1 on: July 08, 2018, 06:46:40 am »
p.s.
Also followed this article:
http://wiki.flexraid.com/2011/06/01/linux-granting-storage-pool-access-to-root-and-other-users/

...not really informative and doesn't seem to achieve desired results.

Offline sergicles

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Can't access pooled storage on Linux
« Reply #2 on: July 08, 2018, 06:53:58 am »
I hate it when I answer my own questions...

For future generations:

cruise control --> Preferences and Settings --> Run-Time Properties -> grant access to Root (change from false to true)

cruise control --> Preferences and Settings --> Run-Time Properties -> grant access to others (change from false to true)