Author Topic: Upgraded to latest ubuntu 18.04.01 and having Activation issue  (Read 170 times)

Offline mdmangus

  • Newbie
  • *
  • Posts: 16
  • Karma: +2/-0
    • View Profile
Upgraded to latest ubuntu 18.04.01 and having Activation issue
« on: December 21, 2018, 11:40:30 am »
Tried submitting through contact us form, but its captcha is shutdown and I can't seem to submit the form.

anyways.

I've upgraded Ubuntu LTS version before.   This time around I am upgrading from Ubuntu 14.04.x LTS to Ubuntu 18.04.1 LTS.  I backed up my configuration.

I installed the OS and did any OS updates.

I downloaded the latest RaidF (2017-11-21) and used the commands in your terminal screenshot on the download page using the raidf-install-mgr.sh script.

I let it install in the default locations.

I restarted and went to the FlexRAID Web Client on port 8080.  It showed I need to activate the product.  I gave it the path to my last used key and it said it imported successfully but activation failed or something close to that.

I then went through my emails and remembered the customer portal for managing licenses at https://secure.flexraid.com.  I updated the window of activation and still go that error.  I then decided to do a pre-registration and it went through but it also gave the same activation failed and the customer licensing portal shows Activated True and Count 3.

I decided to restart and this time when going to port 8080 it doesn't show the activation page and took me into setting up the storage pool so I thought I was good last night and went through article on using the PPU to get previous configuration.  That all went fine and all the existing drives were swapped with no change.

When I go to start the Pool it gives an error License Exception:  is the feature you are trying to use licensed?

So I guess I do still have a license issue.  Nothing on the hardware has changed.

Do you have any suggestions or assistance on getting my RaidF + Pool activated.


Flexraid.log:

[2018-12-21 10:58:46,861] INFO : Setting core service port to 9595
[2018-12-21 10:58:46,881] INFO : Setting Http port to 8080
[2018-12-21 10:58:46,881] INFO : Https port not set. Https requests will not be serviced...
[2018-12-21 10:58:46,883] INFO : Starting FlexRAID...
[2018-12-21 10:58:46,907] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2017.11.21]
[2018-12-21 10:58:47,084] INFO : Started: December 21, 2018 10:58:46 AM CST
[2018-12-21 10:58:48,851] TRACE: keepalive=true
[2018-12-21 10:58:48,851] TRACE: keepalive=true
[2018-12-21 10:58:49,286] TRACE: Attempting to re-mount 45bb694d-5646-4af6-9f59-1666176954f0 at class1_0
[2018-12-21 10:58:49,296] TRACE: Mounting /dev/sdb1 at /root/FlexRAID-Managed-Pool/class1_0/{45bb694d-5646-4af6-9f59-1666176954f0}
[2018-12-21 10:58:49,387] TRACE: Attempting to re-mount b37f459c-ea42-4ef9-8075-6326274f26f1 at class1_0
[2018-12-21 10:58:49,387] TRACE: Mounting /dev/sdc1 at /root/FlexRAID-Managed-Pool/class1_0/{b37f459c-ea42-4ef9-8075-6326274f26f1}
[2018-12-21 10:58:49,459] TRACE: Attempting to re-mount fddf4d03-6f64-405f-9f98-9111e3eccb6b at class1_0
[2018-12-21 10:58:49,459] TRACE: Mounting /dev/sda1 at /root/FlexRAID-Managed-Pool/class1_0/{fddf4d03-6f64-405f-9f98-9111e3eccb6b}
[2018-12-21 10:58:49,519] TRACE: Attempting to re-mount d5a5632e-48d0-4e3a-b102-0d33e7475ba5 at class1_0
[2018-12-21 10:58:49,519] TRACE: Mounting /dev/sdd2 at /root/FlexRAID-Managed-Pool/class1_0/{d5a5632e-48d0-4e3a-b102-0d33e7475ba5}
[2018-12-21 10:58:58,155] INFO : 14
[2018-12-21 10:59:01,078] INFO : F6
[2018-12-21 10:59:44,599] TRACE: Executing: view
[2018-12-21 10:59:44,599] TRACE:    => {"success": false, "status": null, "commandMessages": [{"messageCode": "errorLicenseException", "messageData": []}], "serverMessages": null}
[2018-12-21 10:59:47,554] TRACE: Executing: cruise-control
[2018-12-21 10:59:47,611] TRACE:    => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2018-12-21 10:59:47,612] TRACE: Executing: cruise-control
[2018-12-21 10:59:47,612] TRACE:    => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2018-12-21 10:59:47,612] TRACE: Executing: cruise-control
[2018-12-21 10:59:47,612] TRACE:    => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2018-12-21 10:59:47,612] TRACE: Executing: cruise-control
[2018-12-21 10:59:47,612] TRACE:    => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}
[2018-12-21 10:59:51,940] TRACE: Executing: view
[2018-12-21 10:59:51,940] TRACE:    => {"success": false, "status": null, "commandMessages": [{"messageCode": "errorLicenseException", "messageData": []}], "serverMessages": null}
[2018-12-21 10:59:51,988] TRACE: Executing: view
[2018-12-21 10:59:51,988] TRACE:    => {"success": false, "status": null, "commandMessages": [{"messageCode": "errorLicenseException", "messageData": []}], "serverMessages": null}
[2018-12-21 10:59:51,988] TRACE: Executing: view
[2018-12-21 10:59:51,988] TRACE:    => {"success": false, "status": null, "commandMessages": [{"messageCode": "errorLicenseException", "messageData": []}], "serverMessages": null}
« Last Edit: December 21, 2018, 04:45:39 pm by mdmangus »

Offline mdmangus

  • Newbie
  • *
  • Posts: 16
  • Karma: +2/-0
    • View Profile
Re: Upgraded to latest ubuntu 18.04.01 and having Activation issue
« Reply #1 on: December 21, 2018, 02:37:40 pm »
I went back to the FlexRAID Web Client and looked at the System Control Panel and there is a tab for Reset Activation.

I clicked that button which took me back to the Activation Page and this time I chose to use Purchase Code to Activate.  When I pasted in the purchase code it correctly activated and my Pool configuration was still intact.  I restarted Ubuntu, but now when clicking to start the pool it is giving same error on license exception.

Sigh...   

I see many other users over the past month showing they are having activation issues and that support is limited it seems.

I'll be trying a few more times, but this is going to be a PITA.

Offline mdmangus

  • Newbie
  • *
  • Posts: 16
  • Karma: +2/-0
    • View Profile
Re: Upgraded to latest ubuntu 18.04.01 and having Activation issue
« Reply #2 on: December 21, 2018, 04:42:50 pm »
From reading other older posts around this I guess maybe Brahim needs to update the activation logic against Ubuntu 18.04.1.   For other users having this issue had to re-activate after every restart until Brahim made an update.

So I am guessing that is where I am at with moving up to Ubuntu 18.04.01 LTS.


Offline cogliostrio

  • Jr. Member
  • **
  • Posts: 64
  • Karma: +2/-0
    • View Profile
Re: Upgraded to latest ubuntu 18.04.01 and having Activation issue
« Reply #3 on: December 22, 2018, 04:43:23 am »
Unfortunately Ubuntu 18LTS is not supported.

From the download page
Code: [Select]
Supported distributions are (*):
Ubuntu Linux 14 LTS and its derivatives (including Linux Mint): kernel 3.19.0-80-generic or ABI compatible
Ubuntu Linux 16 LTS and its derivatives (including Linux Mint): kernel 4.10.0-40-generic or ABI compatible
Redhat Enterprise Linux (RHEL) 7/7.x and its derivatives (including CentOS 7/7.x): kernel 3.10 lts
(*) Note that the host package requires a 64 bit OS. However, the Web Client can be installed on both 64 bit and 32 bit systems.

Offline mdmangus

  • Newbie
  • *
  • Posts: 16
  • Karma: +2/-0
    • View Profile
Re: Upgraded to latest ubuntu 18.04.01 and having Activation issue
« Reply #4 on: December 22, 2018, 10:27:23 am »
@cogliostrios,

Thanks.  I can't find that specific distros being listed out like that on the download page for RaidF.

Code: [Select]
Supported distributions are:
All Linux distributions with kernels 2.6 or higher – both 32 bit and 64 bit (*)
LTS releases of Ubuntu and RHEL/CentOS are recommended
(*) Installation manager only targets distributions with apt or yum package managers. All others must do a manual install (MD5: 8b0eeff6319af5bb536bca41aeec92df).
Auto download and installation using the Installation Manager (Debian/Ubuntu/RHEL/CentOS and derivatives) (dl.flexraid.com/raidf-install-mgr.sh)

It does work on 18.04.xxx. It's just the activation needs to be brought up to date for it.  So for now a manual reactivation will have to occur on restarts.

Considering last release was 11-21-2017 makes sense that a update is needed.

I'll hope that eventually an update occurrs until then I'll probably stay with 18.0.4 so that my next 5 years of Ubuntu security updates are supported.  So my next update probably be Ubuntu 22  :D

Warm Regards,


Michael

Offline mdmangus

  • Newbie
  • *
  • Posts: 16
  • Karma: +2/-0
    • View Profile
Re: Upgraded to latest ubuntu 18.04.01 and having Activation issue
« Reply #5 on: December 22, 2018, 10:41:10 am »
@cogliostrios,

Your is listing shows under the tRaid product where it lists out the specific distros.

On RaidF product download page does not.  I agree an update is needed for activation on new ubuntu 18.04.xx when comparing to previous posts about os releasees with activation issues.

Thanks for your reply. 

Offline cogliostrio

  • Jr. Member
  • **
  • Posts: 64
  • Karma: +2/-0
    • View Profile
Re: Upgraded to latest ubuntu 18.04.01 and having Activation issue
« Reply #6 on: December 22, 2018, 02:06:55 pm »
Right, didnt catch which forum I was in. But if it doesnt work, theres probably not much to be done until the dev is back. Maybe try emailing sales?