Author Topic: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !  (Read 6796 times)

Offline cheebster

  • Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Re: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !
« Reply #15 on: March 05, 2012, 09:11:58 am »
Okay ! Parity is the older one i was trying to use.

I think the storage pool wasn't starting because of the references to the old drive LABELS in the windows drive manager.. U sure it ain't that ?

Re-creating parity now, i guess all will be fine after !

CPU is a core i5 750. Will report back !

Offline cheebster

  • Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Re: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !
« Reply #16 on: March 06, 2012, 07:45:15 am »
Seems to work now.. after fresh parity creation, and a reboot.

[2012-03-06 08:43:09,779] INFO : Mounting Storage Pool drive...
[2012-03-06 08:43:24,411] WARN : Could not disable recycle bin settings for drive V

That's the only error i get !


Offline cheebster

  • Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Re: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !
« Reply #18 on: March 06, 2012, 11:57:22 am »
Okay, and then i need to re-create the pool, or on next pool loading the error will not be there anymore ? Thanks !!

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !
« Reply #19 on: March 06, 2012, 01:05:23 pm »
Okay, and then i need to re-create the pool, or on next pool loading the error will not be there anymore ? Thanks !!
No need to recreate.
It should pick it up on the next pool start.

Offline cheebster

  • Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Re: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !
« Reply #20 on: March 07, 2012, 01:43:56 pm »
Hello. It seems unstable for me.. Everything was OK, then i rebooted. Now i start the storage pool, it shows running but, no drive letter. From the log :

[2012-03-07 14:30:40,564] INFO : Initiating FlexRAID Storage Pool...
[2012-03-07 14:30:40,579] INFO : Host OS = Microsoft Windows [version 6.1.7601]
[2012-03-07 14:30:40,579] INFO : Building View Registry...
[2012-03-07 14:30:40,595] INFO : Building Auto View Registry...
[2012-03-07 14:30:40,595] INFO : Loading View options...
[2012-03-07 14:30:54,619] ERROR: Invalid entry detected...
[2012-03-07 14:30:54,619] ERROR: Please run the reconcile operation
[2012-03-07 14:31:13,277] INFO : Using Auto-View definition...
[2012-03-07 14:31:13,277] INFO : Verifying real-time RAID previous exit state...
[2012-03-07 14:31:13,277] INFO : Building View Handler...
[2012-03-07 14:31:13,355] INFO : Mounting Storage Pool drive...
[2012-03-07 14:31:45,701] INFO : Unmounting View...
[2012-03-07 14:31:57,869] INFO : Unmounting View complete...
[2012-03-07 14:31:57,869] INFO : Closing Registry...
[2012-03-07 14:31:57,869] INFO : Closing Registry complete...

I see it says to reconcile, but is that normal when i didn't change anything ? I'm just wondering what causes this. I will run the reconcile.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !
« Reply #21 on: March 07, 2012, 02:18:14 pm »
Was the previous shutdown clean?
Check the sys logs for errors from the previous session.

Offline cheebster

  • Newbie
  • *
  • Posts: 37
  • Karma: +0/-0
    • View Profile
Re: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !
« Reply #22 on: March 09, 2012, 06:55:36 am »
Hi Brahim. I'm really having issues with the storage pool. My system is somewhat clean, nothing weirdo here, no viruses or anything..

Storage pool works fine for a while. Then it stops working good..

Let me explain. Yesterday, all was fine. Come this morning on the pc, i see the drive letter, can access it..

I try to extract a ISO file, read error. Tried a second one, read error as well. Third one, same.. All were ok yesterday.

Now i try to stop the storage pool, it stops. Can't restart it, it doesnt work. I rebooted (clean reboot).. and now still, can't start the storage pool again.

I guess it will need another reconsile, which takes about 8-12 hours on my pc for 3tb.

All i can find in the logs :

[2012-03-09 07:47:42,311] INFO : Verifying real-time RAID previous exit state...
[2012-03-09 07:47:42,311] INFO : Building View Handler...
[2012-03-09 07:47:42,391] INFO : Mounting Storage Pool drive...

Hangs there forever again. I'm about to switch back to snapshot, it really gives me headaches to have to mess with this one everyday :)

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Problem with FlexRaid Storage Pool, RT Raid.. Crashing !
« Reply #23 on: March 10, 2012, 05:34:58 pm »
Let's setup an RDP or Teamviewer session.
PM me with connection info.