Author Topic: Upgraded to 2.1 Storage pool will not start  (Read 1883 times)

Offline yedraid

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Upgraded to 2.1 Storage pool will not start
« on: October 05, 2015, 03:54:35 pm »
Hi, I upgraded to 2.1, uninstalled 2.0 and recreated the array (80 for parity calculation)

The Storage pool will not start. Error message is: ERROR: Storage Pool handler initialization failure!
Running Windows Server 2012 R2

There are no drives with letter V
Changed the letter -- no luck
I ran UserMode.cmd --- no luck
unistalled - rebooted - installed - rebooted -- no luck

Please advise.

Also I lost the registration....will email sales@ about this last issue.

Thanks,

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,504
  • Karma: +201/-16
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #1 on: October 05, 2015, 06:09:56 pm »
Which release date are you running? You can see it by hovering over the globe in the Web UI.

Offline yedraid

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #2 on: October 05, 2015, 08:13:21 pm »
9.25, oh I see a 10.4 update...I will try with that one

Offline yedraid

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #3 on: October 05, 2015, 08:23:11 pm »
well...uninstalled, restarted installed the last one and still have the same error message

This may be useful:
Code: [Select]
[2015-10-05 18:21:23,868] INFO : Setting core service port to 9595
[2015-10-05 18:21:23,868] INFO : Setting Http port to 8080
[2015-10-05 18:21:23,868] INFO : Https port not set. Https requests will not be serviced...
[2015-10-05 18:21:23,868] INFO : Starting FlexRAID...
[2015-10-05 18:21:23,868] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.10.04]
[2015-10-05 18:21:23,868] INFO : Started: October 5, 2015 6:21:23 PM PDT
[2015-10-05 18:21:58,703] INFO : Initiating FlexRAID Storage Pool...
[2015-10-05 18:21:58,821] INFO : Host OS = Microsoft Windows [Version 6.3.9600]
[2015-10-05 18:21:58,822] INFO : Building View Registry...
[2015-10-05 18:21:58,823] INFO : Building Auto View Registry...
[2015-10-05 18:21:58,831] INFO : Loading View options...
[2015-10-05 18:21:58,994] INFO : Using Auto-View definition...
[2015-10-05 18:21:58,994] INFO : Building View Handler...
[2015-10-05 18:21:59,096] INFO : Mounting Storage Pool drive...
[2015-10-05 18:22:13,607] WARN : Active Storage Pool initialization failure... aborting!
[2015-10-05 18:22:13,607] ERROR: Storage Pool handler initialization failure!
java.io.IOException: Storage Pool handler initialization failure!
at com.tchegbe.lib.io.view.g.a.b(Unknown Source)
at com.tchegbe.lib.io.view.g.a.a(Unknown Source)
at com.tchegbe.lib.io.a.b.v.a(Unknown Source)
at com.tchegbe.lib.io.a.f.b(Unknown Source)
at com.tchegbe.lib.io.a.f.a(Unknown Source)
at com.tchegbe.flexraid.main.b.J.initStoragePool(Unknown Source)
at com.tchegbe.flexraid.main.b.A.initStoragePool(Unknown Source)
at com.google.gwt.user.server.rpc.RPC.<unknown>(Unknown Source)
at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(Unknown Source)
at com.google.gwt.user.server.rpc.RemoteServiceServlet.processPost(Unknown Source)
at com.google.gwt.user.server.rpc.AbstractRemoteServiceServlet.doPost(Unknown Source)
at javax.servlet.http.HttpServlet.service(Unknown Source)
at javax.servlet.http.HttpServlet.service(Unknown Source)
at org.eclipse.jetty.servlet.ServletHolder.handle(Unknown Source)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(Unknown Source)
at com.tchegbe.lib.gwt.server.servlet.SecurityFilter.doFilter(Unknown Source)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(Unknown Source)
at org.eclipse.jetty.servlet.ServletHandler.doHandle(Unknown Source)
at org.eclipse.jetty.server.session.SessionHandler.doHandle(Unknown Source)
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(Unknown Source)
at org.eclipse.jetty.servlet.ServletHandler.doScope(Unknown Source)
at org.eclipse.jetty.server.session.SessionHandler.doScope(Unknown Source)
at org.eclipse.jetty.server.handler.ContextHandler.doScope(Unknown Source)
at org.eclipse.jetty.server.handler.ScopedHandler.handle(Unknown Source)
at org.eclipse.jetty.server.handler.HandlerList.handle(Unknown Source)
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(Unknown Source)
at org.eclipse.jetty.server.Server.handle(Unknown Source)
at org.eclipse.jetty.server.HttpConnection.handleRequest(Unknown Source)
at org.eclipse.jetty.server.HttpConnection$RequestHandler.content(Unknown Source)
at org.eclipse.jetty.http.HttpParser.parseNext(Unknown Source)
at org.eclipse.jetty.http.HttpParser.parseAvailable(Unknown Source)
at org.eclipse.jetty.server.BlockingHttpConnection.handle(Unknown Source)
at org.eclipse.jetty.server.bio.SocketConnector$ConnectorEndPoint.run(Unknown Source)
at org.eclipse.jetty.util.thread.QueuedThreadPool.<unknown>(Unknown Source)
at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
« Last Edit: October 05, 2015, 08:27:47 pm by yedraid »

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,504
  • Karma: +201/-16
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #4 on: October 05, 2015, 11:02:29 pm »
Can you set your logs to TRACE and retry?

Offline yedraid

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #5 on: October 06, 2015, 01:11:26 am »
Strange, the logs dont look more verbose to me..I wonder if the TRACE change worked correctly.

This the FlexRaid.log file:
Code: [Select]
[2015-10-05 23:01:42,676] INFO : Setting core service port to 9595
[2015-10-05 23:01:42,676] INFO : Setting Http port to 8080
[2015-10-05 23:01:42,676] INFO : Https port not set. Https requests will not be serviced...
[2015-10-05 23:01:42,676] INFO : Starting FlexRAID...
[2015-10-05 23:01:42,676] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.10.04]
[2015-10-05 23:01:42,676] INFO : Started: October 5, 2015 11:01:42 PM PDT
[2015-10-05 23:01:47,433] INFO : Initiating FlexRAID Storage Pool...
[2015-10-05 23:01:47,461] INFO : Host OS = Microsoft Windows [Version 6.3.9600]
[2015-10-05 23:01:47,461] INFO : Building View Registry...
[2015-10-05 23:01:47,461] INFO : Building Auto View Registry...
[2015-10-05 23:01:47,503] INFO : Loading View options...
[2015-10-05 23:01:47,531] INFO : Using Auto-View definition...
[2015-10-05 23:01:47,531] INFO : Building View Handler...
[2015-10-05 23:01:47,631] INFO : Mounting Storage Pool drive...
[2015-10-05 23:02:01,143] WARN : Active Storage Pool initialization failure... aborting!
[2015-10-05 23:02:01,143] ERROR: Storage Pool handler initialization failure!
java.io.IOException: Storage Pool handler initialization failure!
at com.tchegbe.lib.io.view.g.a.b(Unknown Source)
at com.tchegbe.lib.io.view.e.c.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
[2015-10-05 23:02:43,255] INFO : Initiating FlexRAID Storage Pool...
[2015-10-05 23:02:43,271] INFO : Host OS = Microsoft Windows [Version 6.3.9600]
[2015-10-05 23:02:43,271] INFO : Building View Registry...
[2015-10-05 23:02:43,271] INFO : Building Auto View Registry...
[2015-10-05 23:02:43,286] INFO : Loading View options...
[2015-10-05 23:02:43,318] INFO : Using Auto-View definition...
[2015-10-05 23:02:43,318] INFO : Building View Handler...
[2015-10-05 23:02:43,427] INFO : Mounting Storage Pool drive...
[2015-10-05 23:02:55,980] WARN : Active Storage Pool initialization failure... aborting!
[2015-10-05 23:02:55,980] ERROR: Storage Pool handler initialization failure!
java.io.IOException: Storage Pool handler initialization failure!
at com.tchegbe.lib.io.view.g.a.b(Unknown Source)
at com.tchegbe.lib.io.view.g.a.a(Unknown Source)
at com.tchegbe.lib.io.a.b.v.a(Unknown Source)
at com.tchegbe.lib.io.a.f.b(Unknown Source)
at com.tchegbe.lib.io.a.f.a(Unknown Source)
at com.tchegbe.flexraid.main.b.J.initStoragePool(Unknown Source)
at com.tchegbe.flexraid.main.b.A.initStoragePool(Unknown Source)
at com.google.gwt.user.server.rpc.RPC.<unknown>(Unknown Source)
at com.google.gwt.user.server.rpc.RemoteServiceServlet.processCall(Unknown Source)
at com.google.gwt.user.server.rpc.RemoteServiceServlet.processPost(Unknown Source)
at com.google.gwt.user.server.rpc.AbstractRemoteServiceServlet.doPost(Unknown Source)
at javax.servlet.http.HttpServlet.service(Unknown Source)
at javax.servlet.http.HttpServlet.service(Unknown Source)
at org.eclipse.jetty.servlet.ServletHolder.handle(Unknown Source)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(Unknown Source)
at com.tchegbe.lib.gwt.server.servlet.SecurityFilter.doFilter(Unknown Source)
at org.eclipse.jetty.servlet.ServletHandler$CachedChain.doFilter(Unknown Source)
at org.eclipse.jetty.servlet.ServletHandler.doHandle(Unknown Source)
at org.eclipse.jetty.server.session.SessionHandler.doHandle(Unknown Source)
at org.eclipse.jetty.server.handler.ContextHandler.doHandle(Unknown Source)
at org.eclipse.jetty.servlet.ServletHandler.doScope(Unknown Source)
at org.eclipse.jetty.server.session.SessionHandler.doScope(Unknown Source)
at org.eclipse.jetty.server.handler.ContextHandler.doScope(Unknown Source)
at org.eclipse.jetty.server.handler.ScopedHandler.handle(Unknown Source)
at org.eclipse.jetty.server.handler.HandlerList.handle(Unknown Source)
at org.eclipse.jetty.server.handler.HandlerWrapper.handle(Unknown Source)
at org.eclipse.jetty.server.Server.handle(Unknown Source)
at org.eclipse.jetty.server.HttpConnection.handleRequest(Unknown Source)
at org.eclipse.jetty.server.HttpConnection$RequestHandler.content(Unknown Source)
at org.eclipse.jetty.http.HttpParser.parseNext(Unknown Source)
at org.eclipse.jetty.http.HttpParser.parseAvailable(Unknown Source)
at org.eclipse.jetty.server.BlockingHttpConnection.handle(Unknown Source)
at org.eclipse.jetty.server.bio.SocketConnector$ConnectorEndPoint.run(Unknown Source)
at org.eclipse.jetty.util.thread.QueuedThreadPool.<unknown>(Unknown Source)
at org.eclipse.jetty.util.thread.QueuedThreadPool$3.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

and this is the FlexRAID.sys.c1-1.log file
Code: [Select]
[2015-10-05 23:01:44.431604][2808][DLL_THREAD_ATTACH] ID=2808
[2015-10-05 23:01:47.634307][2240]Build Timestamp [Oct  4 2015 17:19:09]
[2015-10-05 23:01:47.634308][2240]


--------------- Storage Pool Start ---------------
[2015-10-05 23:01:47.634308][2240][Mounting Storage Pool]
[2015-10-05 23:01:47.634308][2240][VM already acquired...]
[2015-10-05 23:01:47.634309][2240][Building options...]
[2015-10-05 23:01:54.666421][2240][OnMount]
[2015-10-05 23:01:54.667422][2240] [OnMount] => Exited...
[2015-10-05 23:01:54.723619][3672][OnUnmount]
[2015-10-05 23:01:54.723621][3672] [OnUnmount] => Exited...
[2015-10-05 23:02:00.734658][2240][mount] [Create New Storage Pool] ErrorCode=31 Message=Mount error! Code=87 Message=The parameter is incorrect.


[2015-10-05 23:02:43.428598][3408]Build Timestamp [Oct  4 2015 17:19:09]
[2015-10-05 23:02:43.428598][3408]


--------------- Storage Pool Start ---------------
[2015-10-05 23:02:43.428599][3408][Mounting Storage Pool]
[2015-10-05 23:02:43.428599][3408][VM already acquired...]
[2015-10-05 23:02:43.428599][3408][Building options...]
[2015-10-05 23:02:50.464769][3408][OnMount]
[2015-10-05 23:02:50.479769][3408] [OnMount] => Exited...
[2015-10-05 23:02:50.526967][0712][OnUnmount]
[2015-10-05 23:02:50.526967][0712] [OnUnmount] => Exited...
[2015-10-05 23:02:55.559044][3408][mount] [Create New Storage Pool] ErrorCode=31 Message=Mount error! Code=87 Message=The parameter is incorrect.

Thanks


Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,504
  • Karma: +201/-16
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #6 on: October 06, 2015, 01:42:04 am »
You need to restart the service after changing the log level.
Also, take a screenshot of <install directory>\ext.
It is quite possible that it is trying to use the old driver.

Offline yedraid

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #7 on: October 06, 2015, 09:51:28 am »
I restarted the server and logs are identical...

I changed the file "logging.options.txt" in folder "C:\Program Files (x86)\FlexRAID\RAID-F 2.1" to

Code: [Select]
#The options for the log levels are: ERROR, WARN, INFO, TRACE

#The directory where to put all FlexRAID logs
FLEXRAID_LOG_FILE_ROOT=C:\

#The log level for the higher level FlexRAID logs (FlexRAID.log)
FLEXRAID_LOG_LEVEL=TRACE

#The log level for the lower level FlexRAID logs (FlexRAID.[sys|NIO|WNOS|NOS|DM].log)
FLEXRAID_SYS_LOG_LEVEL=TRACE

Attached is the screenshot of ext directory, thanks

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,504
  • Karma: +201/-16
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #8 on: October 06, 2015, 10:30:04 am »
Please edit <install root>\log4j.property and remove the line that says "log4j.logger.com.tchegbe=INFO".
It is overriding the first line that takes the dynamic value.

Offline yedraid

  • Newbie
  • *
  • Posts: 11
  • Karma: +0/-0
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #9 on: October 06, 2015, 10:59:25 am »
Now I see more info


FlexRAID.log

Code: [Select]
[2015-10-06 09:01:53,717] INFO : Setting core service port to 9595
[2015-10-06 09:01:53,717] INFO : Setting Http port to 8080
[2015-10-06 09:01:53,717] INFO : Https port not set. Https requests will not be serviced...
[2015-10-06 09:01:53,717] INFO : Starting FlexRAID...
[2015-10-06 09:01:53,717] INFO : FlexRAID 2.1 [Snapshot 1.1 / Storage Pool 2.0] [2015.10.04]
[2015-10-06 09:01:53,733] INFO : Started: October 6, 2015 9:01:53 AM PDT
[2015-10-06 09:01:53,920] TRACE: keepalive=true
[2015-10-06 09:01:53,920] TRACE: keepalive=true
[2015-10-06 09:01:58,449] TRACE: Starting the Storage Pool - checking if instance is active...
[2015-10-06 09:01:58,449] TRACE: Starting the Storage Pool - checking if reboot is required...
[2015-10-06 09:01:58,450] TRACE: Starting the Storage Pool - validating dependencies...
[2015-10-06 09:01:58,450] INFO : Initiating FlexRAID Storage Pool...
[2015-10-06 09:01:58,477] INFO : Host OS = Microsoft Windows [Version 6.3.9600]
[2015-10-06 09:01:58,477] INFO : Building View Registry...
[2015-10-06 09:01:58,478] INFO : Building Auto View Registry...
[2015-10-06 09:01:58,518] INFO : Loading View options...
[2015-10-06 09:01:58,523] DEBUG: Processing match list...
[2015-10-06 09:01:58,523] DEBUG: Processing unique roots...
[2015-10-06 09:01:58,523] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{7aeeccc2-ecad-11e4-80b3-1c6f6524901d}
[2015-10-06 09:01:58,524] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{8dceb40a-ecf3-11e4-80b4-1c6f6524901d}
[2015-10-06 09:01:58,524] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{71ccb852-9fdb-41bc-86d2-14a0fad672c3}
[2015-10-06 09:01:58,525] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{1f868357-1f84-43d8-ae94-f56ff6ea9c1f}
[2015-10-06 09:01:58,526] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{d9bd08d0-2cc9-4e14-b76e-c05211b10c42}
[2015-10-06 09:01:58,526] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{b0f7659e-8964-479a-8966-da706b1f96e1}
[2015-10-06 09:01:58,527] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{c81450e5-9c56-4b3e-836a-b8eff558bff3}
[2015-10-06 09:01:58,527] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{f1d9a911-7d82-4473-a896-7700f8b0d2e4}
[2015-10-06 09:01:58,528] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{cb195d9a-18cc-403e-ac79-dff375cbb373}
[2015-10-06 09:01:58,529] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{27935202-0ff2-4944-a4eb-a89ec8e53e75}
[2015-10-06 09:01:58,529] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{0baa1d19-fd7d-4089-b02d-98e064932a1f}
[2015-10-06 09:01:58,529] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{aef42f92-0f11-4d45-a017-8a12f76698e1}
[2015-10-06 09:01:58,530] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{79a1a79f-e21d-4a42-b565-6737990297ef}
[2015-10-06 09:01:58,530] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{f21484df-3e6c-4a36-8573-db3c99aac894}
[2015-10-06 09:01:58,531] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{c7904de4-0151-460b-a62f-d86abab9218b}
[2015-10-06 09:01:58,532] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{4c7fea39-1479-4051-88c6-bcf8419c4267}
[2015-10-06 09:01:58,532] DEBUG: Processing unique root: C:\FlexRAID-Managed-Pool\class1_0\{1f93f173-6434-4061-8688-35e5901b7517}
[2015-10-06 09:01:58,533] TRACE: Loading AutoRegistry options...
[2015-10-06 09:01:58,533] TRACE: Completing AutoRegistry options...
[2015-10-06 09:01:58,545] TRACE: Loading View definition...
[2015-10-06 09:01:58,545] INFO : Using Auto-View definition...
[2015-10-06 09:01:58,545] INFO : Building View Handler...
[2015-10-06 09:01:58,644] INFO : Mounting Storage Pool drive...
[2015-10-06 09:02:12,155] WARN : Active Storage Pool initialization failure... aborting!
[2015-10-06 09:02:12,155] ERROR: Storage Pool handler initialization failure!
java.io.IOException: Storage Pool handler initialization failure!
at com.tchegbe.lib.io.view.g.a.b(Unknown Source)
at com.tchegbe.lib.io.view.e.c.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
[2015-10-06 09:02:12,155] TRACE: Checking and executing after pool start instructions..

and FlexRAID.sys.c1-1.log

Code: [Select]
[2015-10-06 09:01:55.450669][0992][DLL_THREAD_ATTACH] ID=992
[2015-10-06 09:01:58.647359][3000]Build Timestamp [Oct  4 2015 17:19:09]
[2015-10-06 09:01:58.647359][3000]


--------------- Storage Pool Start ---------------
[2015-10-06 09:01:58.647360][3000][Mounting Storage Pool]
[2015-10-06 09:01:58.647360][3000][VM already acquired...]
[2015-10-06 09:01:58.647360][3000][Building options...]
[2015-10-06 09:02:05.668432][3000][OnMount]
[2015-10-06 09:02:05.668433][3000] [OnMount] => Exited...
[2015-10-06 09:02:05.732657][2972][OnUnmount]
[2015-10-06 09:02:05.733658][2972] [OnUnmount] => Exited...
[2015-10-06 09:02:11.747709][3000][mount] [Create New Storage Pool] ErrorCode=31 Message=Mount error! Code=87 Message=The parameter is incorrect.



Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,504
  • Karma: +201/-16
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #10 on: October 06, 2015, 11:49:36 am »
Please setup a remote connection and PM me the login info.
I will take a peak.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,504
  • Karma: +201/-16
    • View Profile
Re: Upgraded to 2.1 Storage pool will not start
« Reply #11 on: October 06, 2015, 05:40:21 pm »
Here is a resolution for those affected by this issue.

It seems like mounting the pool as removable disk fails on some systems. Mounting it as a fixed disk works fine.
As a short term resolution, please change the "removable" property value to false under "Preferences and Setttings -> Run-Time Properties -> Advanced Properties".

I will keep an eye on the issue for a more complete resolution.