Author Topic: Cannot add Drives to Storage Pool  (Read 1113 times)

Offline Gregg

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Cannot add Drives to Storage Pool
« on: October 07, 2015, 12:52:29 am »
Hi everyone-
I looked for an answer but was not able to find anything that helped solve my issue.

I just upgraded from Windows 7 (storage pool was running fine) to Windows 10 then successfully installed FlexRAID-2.1-Final-2015-10-04.  I am now trying to get my Storage Pool back up and having issues.

I first added my Parity drive then Drive 3 and 4 of the storage pool using the Restore only option.  They are added to storage pool and the status on all three is Healthy but I did get the following error after adding each:

ERROR: Delete mount Error=2 - Message=No such file or directory

When trying to add Drive 1 and 2, I get this error:
ERROR: Unexpected content found at 74472ec9-94f4-11e3-ad69-806e6f6e6963! Cannot mount C:\FlexRAID-Managed-Pool\class1_0\{74472ec9-94f4-11e3-ad69-806e6f6e6963}

These 2 drives are not added to the pool.

I tried starting completely over by creating a new Drive Pool but get the same error when trying to add Drive 1 and 2. 

Any thoughts on how to troubleshoot this issue is greatly appreciated.
Thanks!

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Cannot add Drives to Storage Pool
« Reply #1 on: October 07, 2015, 07:08:10 am »
Go to the path specified (C:\FlexRAID-Managed-Pool\class1_0\{74472ec9-94f4-11e3-ad69-806e6f6e6963}) and move the content found there.

Offline Gregg

  • Newbie
  • *
  • Posts: 9
  • Karma: +0/-0
    • View Profile
Re: Cannot add Drives to Storage Pool
« Reply #2 on: October 07, 2015, 10:54:15 am »
Thank you!  that was a huge help.  It took a bit of work but I am now back up.

For anyone else with this issue, here is what I did.
1. I could not see the folder initially so went to File Explorer Options and unchecked Hide Protected operating system files
2.  Now that I could see C:\FlexRAID-Managed-Pool when I tried to open it I got an access denied error so I right clicked on the file, selected Properties then the Security tab then clicked advanced and added a new entry that allowed me to access the folder.  I kept getting the same error pointed to a different folder so ultimately I removed the entire folder
3. uninstalled Flexraid, copied FlexRAID-Config.db to C:\ from a backup installed Flexraid again then restored my drives without issue.

Hope this helps,
Thanks again