Author Topic: 2.1 missing "Explicit" Merge Mode, Pool won't start  (Read 1135 times)

Offline kl1688

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
2.1 missing "Explicit" Merge Mode, Pool won't start
« on: October 15, 2015, 04:11:37 pm »
After upgrading to 2.1, the "Explicit" Merge Mode radio button is missing and the pool will not start when trying to "Publish/(Re-)Start".  I had "Explicit" selected when I was on 2.0, uninstalling 2.1 and reinstalling 2.0 returns the missing mode and the pool starts fine.  Using latest Chrome, cleared cache, Windows 7 64-bit.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,541
  • Karma: +204/-16
    • View Profile
Re: 2.1 missing "Explicit" Merge Mode, Pool won't start
« Reply #1 on: October 15, 2015, 04:25:03 pm »
Explicit Merge Mode has been disabled in the latest release. It might be re-added in future releases. The goal is to re-work it from scratch.

Offline kl1688

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 2.1 missing "Explicit" Merge Mode, Pool won't start
« Reply #2 on: October 17, 2015, 01:24:05 pm »
Thanks. Is there an ETA on this update?  How do I get the pool to start on 2.1 in the meantime?  Do I need to redo my pool config? Which merge mode would approximate "Explicit"? Thanks

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,541
  • Karma: +204/-16
    • View Profile
Re: 2.1 missing "Explicit" Merge Mode, Pool won't start
« Reply #3 on: October 17, 2015, 03:54:14 pm »
You will need to redo the config and switch to one of the auto modes.

Offline kl1688

  • Newbie
  • *
  • Posts: 3
  • Karma: +0/-0
    • View Profile
Re: 2.1 missing "Explicit" Merge Mode, Pool won't start
« Reply #4 on: October 29, 2015, 11:35:13 am »
Which Auto Mode and setup most closely matches what the Explicit Mode does?  I want same named folders on various drives to be represented by a single folder on the pool volume. For example all "Movies" folders, all "TV" folders, all "Application" folders on multiple drives should be merged on the pool volume.  Thanks

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,541
  • Karma: +204/-16
    • View Profile
Re: 2.1 missing "Explicit" Merge Mode, Pool won't start
« Reply #5 on: October 29, 2015, 11:42:43 am »
Use the auto folder priority mode.

Offline sireddie

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: 2.1 missing "Explicit" Merge Mode, Pool won't start
« Reply #6 on: March 28, 2017, 07:17:42 am »
Reviving this thread.

Long time user of Explicit mode, I have been running FlexRAID on Win 7 (on 2.0 final [2014-08-16] ) up until now when upgrading to a new server with Win 10.

New server is fully prepped for cutover and as I'm about to do the final preparations I find out that Explicit merge mode (or Explicit view mode) has been disabled in v 2.1 (which adds support for Windows 10).

I really need Explicit mode for ensuring data ends up where I need it to (mainly for performance of subsequent file move operations).

Can I run 2.0 on Win 10?
Can Explicit mode be enabled again (please)? Perhaps via registry key to keep unintentional problems for users?

I would be forever grateful if it would be possible to solve my dilemma somehow.

Thanks,

Eddie

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,541
  • Karma: +204/-16
    • View Profile
Re: 2.1 missing "Explicit" Merge Mode, Pool won't start
« Reply #7 on: March 28, 2017, 03:13:13 pm »
There is plan to bring back Explicit Mode. It is the mode I preferred myself. The issue was that too many people were getting themselves into trouble not properly understanding it. The Auto mode is simpler but not as optimal as properly configured Explicit Mode.

For my own use, I do plan to bring back Explicit Mode. No ETA though.

Offline sireddie

  • Newbie
  • *
  • Posts: 19
  • Karma: +0/-0
    • View Profile
Re: 2.1 missing "Explicit" Merge Mode, Pool won't start
« Reply #8 on: March 29, 2017, 08:15:31 am »
Ok thanks for the info.

I guess I'll use folder prioritisation until Expert mode is available again.