Author Topic: FlexRAID fails to start after no issues for a few years...  (Read 729 times)

Offline endoracing

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-0
    • View Profile
FlexRAID fails to start after no issues for a few years...
« on: November 06, 2015, 07:05:10 pm »
I tried to write to the storage pool and got permission denied errors so I restarted my server and now FlexRAID wont start at all. If I manually run sudo ./FlexRAID I get the following:

jeff@PhenomServer:/var/lib/flexraid$ sudo ./FlexRAID
FlexRAID initialized successfully....
terminate called after throwing an instance of 'CryptoPP::InvalidCiphertext'
  what():  RSA/OAEP-MGF1(Whirlpool): invalid ciphertext
jeff@PhenomServer:/var/lib/flexraid$


the Log shows this:
[2015-11-06 20:07:25,083] INFO : Setting core service port to 9595
[2015-11-06 20:07:25,084] INFO : Setting Http port to 8080
[2015-11-06 20:07:25,084] INFO : Https port not set. Https requests will not be serviced...
[2015-11-06 20:07:25,085] INFO : Starting FlexRAID...
[2015-11-06 20:07:25,085] INFO : FlexRAID 2.0u12 final [Snapshot 1.4 stable / Storage Pool 1.0 stable / Real-Time 1.0 experimental]
[2015-11-06 20:07:25,087] INFO : Started: November 6, 2015 8:07:25 PM EST
[2015-11-06 20:07:25,255] INFO : Initialized Scheduler Signaller of type: class org.quartz.core.SchedulerSignalerImpl
[2015-11-06 20:07:25,255] INFO : Quartz Scheduler v.1.8.4 created.
[2015-11-06 20:07:25,255] INFO : Registering Quartz shutdown hook.
[2015-11-06 20:07:25,255] INFO : Using thread monitor-based data access locking (synchronization).
[2015-11-06 20:07:25,261] INFO : Removed 0 Volatile Trigger(s).
[2015-11-06 20:07:25,261] INFO : Removed 0 Volatile Job(s).
[2015-11-06 20:07:25,262] INFO : JobStoreTX initialized.
[2015-11-06 20:07:25,262] INFO : Scheduler meta-data: Quartz Scheduler (v1.8.4) 'flexraid' with instanceId '1'
  Scheduler class: 'org.quartz.core.QuartzScheduler' - running locally.
  NOT STARTED.
  Currently in standby mode.
  Number of jobs executed: 0
  Using thread pool 'org.quartz.simpl.SimpleThreadPool' - with 10 threads.
  Using job-store 'org.quartz.impl.jdbcjobstore.JobStoreTX' - which supports persistence. and is not clustered.

[2015-11-06 20:07:25,262] INFO : Quartz scheduler 'flexraid' initialized from default resource file in Quartz package: 'quartz.properties'
[2015-11-06 20:07:25,262] INFO : Quartz scheduler version: 1.8.4
[2015-11-06 20:07:25,356] INFO : Freed 0 triggers from 'acquired' / 'blocked' state.
[2015-11-06 20:07:25,357] INFO : Recovering 0 jobs that were in-progress at the time of the last shut-down.
[2015-11-06 20:07:25,357] INFO : Recovery complete.
[2015-11-06 20:07:25,357] INFO : Removed 0 'complete' triggers.
[2015-11-06 20:07:25,357] INFO : Removed 0 stale fired job entries.
[2015-11-06 20:07:25,357] INFO : Scheduler flexraid_$_1 started.
[2015-11-06 20:07:25,491] INFO : jetty-7.x.y-SNAPSHOT
[2015-11-06 20:07:25,501] INFO : started o.e.j.s.ServletContextHandler{/,null}
[2015-11-06 20:07:25,501] TRACE: keepalive=true
[2015-11-06 20:07:25,501] TRACE: keepalive=true
[2015-11-06 20:07:26,511] TRACE: Attempting to re-mount 966e158a-24a0-4a23-9f49-70e3120c19e5 at class1_0
[2015-11-06 20:07:26,512] WARN : Partition not found for 966e158a-24a0-4a23-9f49-70e3120c19e5!
java.io.IOException: Partition not found for 966e158a-24a0-4a23-9f49-70e3120c19e5!
        at java.lang.Void.<unknown>(Unknown Source)
        at java.lang.Void.<unknown>(Unknown Source)
        at java.lang.Void.<unknown>(Unknown Source)
        at java.lang.Void.<unknown>(Unknown Source)
[2015-11-06 20:07:26,512] TRACE: Attempting to re-mount 077b4fe6-0ca9-4835-b234-3435e6f032ca at class1_0
[2015-11-06 20:07:27,532] TRACE: Attempting to re-mount 716d3bd6-fb21-4968-a428-9c908d0aebea at class1_0
[2015-11-06 20:07:27,532] TRACE: Attempting to re-mount 25dca2c3-55f6-4ddf-abe0-8c2e78cf72ec at class1_0
[2015-11-06 20:07:27,532] TRACE: Attempting to re-mount f6165107-04da-4f06-85d1-7d1a7bacce2b at class1_0
[2015-11-06 20:07:27,532] TRACE: Executing: smart
[2015-11-06 20:07:27,532] TRACE:        => {"success": true, "status": null, "commandMessages": [], "serverMessages": null, "infos": []}

If I start it as my user with no sudo I get this:
jeff@PhenomServer:/var/lib/flexraid$ ./FlexRAID
log4j:ERROR setFile(null,true) call failed.
java.io.FileNotFoundException: /tmp/FlexRAID.log
        at java.lang.Void.<unknown>(Unknown Source)
        at java.lang.Void.<unknown>(Unknown Source)
        at java.lang.Void.<unknown>(Unknown Source)
        at java.lang.Void.<unknown>(Unknown Source)
FlexRAID initialized successfully....
fusermount: failed to open /etc/fuse.conf: Permission denied
fusermount: user has no write access to mountpoint /media/flexraid

and it stays running but cant start the pool.


System is Ubuntu 12.04 LTS 64 bit, the about on the FlexRAID config page is "2.0u12 final [Snapshot 1.4 stable / Storage Pool 1.0 stable / Real-Time 1.0 experimental]" I'm not sure whats happening. Its been installed for about 3 years and asside from a few issues where I had to restart a couple times its always worked. Any insight appreciated.

Thanks,
Jeff Schultz
« Last Edit: November 06, 2015, 07:18:39 pm by endoracing »

Offline endoracing

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-0
    • View Profile
Re: FlexRAID fails to start after no issues for a few years...
« Reply #1 on: November 06, 2015, 07:32:13 pm »
did an apt-get upgrade and now its working. Not sure why but at least its back up.

Offline endoracing

  • Newbie
  • *
  • Posts: 16
  • Karma: +1/-0
    • View Profile
Re: FlexRAID fails to start after no issues for a few years...
« Reply #2 on: December 02, 2015, 06:55:20 pm »
And after a reboot its back to not working again ... any thoughts are appreciated

edit: did another sudo apt-get upgrade as well as apt-get remove virtualbox and samba4 .. started up again. Still no clue what the issue is and I'm scared to try a reboot again and not be able to get it back.
« Last Edit: December 02, 2015, 07:03:51 pm by endoracing »