Author Topic: Correct Way to setup Specific Folder Shares w SP only on 2.1 2015-11-01 release  (Read 1048 times)

Offline LocknLoad

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Hi,

Loosing my mind trying to figure out the current/correct way to share a few folders off my storage pool.
I keep loosing the shares between restarts.

I had this working and since upgrading to 2.1 2015-11-01 it no longer works.

Have deleted configuration twice and started from scratch without success.
I have attached some screenshots of the configuration options that I have been using.

Tried with and without 'Server Share UI' (Can not recall if I had this option configured previously)
Tried with and without 'External Network Shares' (I had this configured previously when it worked)
I have click countless times on 'Storage Pool -> Backup Server Shares'

Need help and guidance here please.

Thanks.

Offline LocknLoad

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
I create the shares as follows
Windows Explorer -> Properties -> Sharing -> Adv Sharing -> Share Folder -> Permissions -> Everyone -> Read

Offline LocknLoad

  • Newbie
  • *
  • Posts: 12
  • Karma: +0/-0
    • View Profile
Did a complete configuration wipe and a downgrade install to 2.1 [2015-10-04].
Shares still disappear after restarts.

Anyone have any screenshots of a similar setup that is working?

Win 7 x64 Ult
Flexraid-F Storage pool only - Expert Mode

Appreciate any help or feedback.
« Last Edit: February 01, 2016, 11:41:13 am by LocknLoad »

Offline Newhaven

  • Newbie
  • *
  • Posts: 39
  • Karma: +3/-0
    • View Profile
Looks like you are running in expert mode. I think that the enable server share ui option is meant only for cruise control (you can selectively share certain folders which you setup the same as in 2.0). Without this option enabled in cruise control (2.1 versions), i think the entire pool must be shared.

Other than that, it looks like you sharing in expert mode correctly. Have you checked the flexraid logs for potential clues?
« Last Edit: February 06, 2016, 07:51:24 pm by Newhaven »

Offline Jaymaeosn

  • Newbie
  • *
  • Posts: 1
  • Karma: +0/-0
    • View Profile
I view it as the most likely to have thoughts of their own time.

Offline siu99ss2

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Hi OP,

I having the same issues with network share disappearing after restart. Also using latest version of flexraid in expert mode and also didn't have any problems when shares were configured within fr control panel in previous version.

Have you had any luck in resolving this - it's very frustrating having to readd shares

Thanks

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,385
  • Karma: +201/-15
    • View Profile
With the latest release and when using the new configuration mode, shares must be configured on the pool disk and not a folder within the pool.

If using the old configuration mode, do post a screenshot of your Server Shares configurations. Also, provide full logs in TRACE mode as there should be entries relating to re-connecting the custom shares.

Offline poggsuk

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Another person here who simply cant get the shares to stick.

Just downgrade to 2.0.  It works.

2.1 is clearly buggy and or too unintuitive for normal people to get working.

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,385
  • Karma: +201/-15
    • View Profile
Actually, shares in 2.1 should be configured as normal through Windows Explorer and Windows itself will remember them.
See this topic: http://forum.flexraid.com/index.php/topic,49172.0.html

Offline poggsuk

  • Newbie
  • *
  • Posts: 4
  • Karma: +0/-0
    • View Profile
Sorry Brahim,

Latest version.  New reinstall of whs2011.  Shares simply dont stick after a reboot.

I do indeed configure them via the window explorer.  Shares can then be seen across the netwok.  As soon as I reboot the server, the shares disappear.

I have a storage pool only licence and configure with expert mode.

Having to run 2.0 to get shares to stick.

« Last Edit: February 26, 2017, 02:49:38 pm by poggsuk »