Author Topic: Impossible to run Flexraid on Squeeze x64  (Read 2039 times)

Offline beut

  • Newbie
  • *
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Impossible to run Flexraid on Squeeze x64
« on: March 26, 2012, 12:43:32 am »
Hello,

I'm a newbie on Linux and I've tried to install Flexraid on Debian squeeze server (with Open Media vault installed), without success.
That's what I've done:

- installed ia32-libs
- made /home/"username"/flexraid directory and chmod o+w on it
- add "username" to fuse group
- uncommented "user_allow_other" in /etc/fuse.conf
- made executable and run Flexraid.bin in  /home/"username"/flexraid
- chmod o=rx on  /home/"username"/flexraid
- FlexRAID-Config.db is in /home/"username" and -rw-r--r-- rights on it.
- cd /home/"username"/flexraid and type ./FlexRAID &

I can see "[1]" or "[2]" and 4 digits like "2221" or "4012" at prompt and nothing more...

So, thanks a lot for your help.
« Last Edit: March 26, 2012, 12:52:46 am by beut »
Lian Li PC-Q25 | Intel DQ64 MB | i5 2400s | 8 Gb RAM | 1 SSD for OMV | 6 x 2Tb HDD with FlexRAID

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Impossible to run Flexraid on Squeeze x64
« Reply #1 on: March 26, 2012, 11:18:45 am »
1. Make sure you are running GLIBC version 2.11 or higher.
Find your version by issuing "ldd --version"

2. Run ldd on the executable to get the full list of dependencies for your distro.
Ex: ldd FlexRAID

3. Run FlexRAID is foreground so that you can see any error in the shell console
./FlexRAID (instead of ./FlexRAID &)


« Last Edit: March 26, 2012, 11:20:52 am by Brahim »

Offline beut

  • Newbie
  • *
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: Impossible to run Flexraid on Squeeze x64
« Reply #2 on: March 26, 2012, 12:20:47 pm »
Hello Brahim and thanks for the help  ;).

1. ldd version 2.11.3

2.  ldd FlexRAID
        linux-gate.so.1 =>  (0xf771c000)
        libpthread.so.0 => /lib32/libpthread.so.0 (0xf76f7000)
        libc.so.6 => /lib32/libc.so.6 (0xf75b0000)
        libdl.so.2 => /lib32/libdl.so.2 (0xf75ab000)
        /lib/ld-linux.so.2 (0xf771d000)

3. After ./FlexRAID (no & after), screen stays black but I can see FlexRAID GUI at http://my_ip:8080  ;D
That's just perfect!

I can confirm that FlexRAID perfectly works on OpenMediaVault.
Thanks again.
Lian Li PC-Q25 | Intel DQ64 MB | i5 2400s | 8 Gb RAM | 1 SSD for OMV | 6 x 2Tb HDD with FlexRAID

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Impossible to run Flexraid on Squeeze x64
« Reply #3 on: March 26, 2012, 12:59:25 pm »
This is awesome.
Do you mind setting up a guide on the integration for others to follow?

That would be much appreciated. :)

Offline beut

  • Newbie
  • *
  • Posts: 39
  • Karma: +0/-0
    • View Profile
Re: Impossible to run Flexraid on Squeeze x64
« Reply #4 on: March 26, 2012, 01:22:00 pm »
Just done for the first part (installation) on the OpenMediaVault thread  ;D

I' m going to set up my pool for Real time Raid.
When I will have done it and the sharing too, I will add it to the thread.

See you soon...

Lian Li PC-Q25 | Intel DQ64 MB | i5 2400s | 8 Gb RAM | 1 SSD for OMV | 6 x 2Tb HDD with FlexRAID

Offline Brahim

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 8,547
  • Karma: +204/-16
    • View Profile
Re: Impossible to run Flexraid on Squeeze x64
« Reply #5 on: March 26, 2012, 03:29:11 pm »
Great. Thanks. :)