Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - tonym

Pages: [1] 2 3 ... 7
1
Snapshot RAID / Re: Quick-validate error: ZipException
« on: December 13, 2017, 03:14:14 am »
Thanks again Brahim.

Hopefully a disk format and full parity re-build will help restore Update performance which had been becoming slower of late. I'm assuming this was because after 18 months of file deletes/adds my RAID had become somewhat fragmented.

2
Snapshot RAID / Re: Quick-validate error: ZipException
« on: December 12, 2017, 01:10:49 pm »
Thanks.

I wish I'd known that yesterday; I was having space problems so they got manually deleted. And are no longer available even using WinUndelete.

Looks like a full Parity rebuild required. :(

3
Snapshot RAID / Quick-validate error: ZipException
« on: December 12, 2017, 09:16:30 am »
All of a sudden, FlexRAID has stopped working for me, I'm getting the following error message:

[2017-12-12 14:58:30,736] INFO : Executing quick-validate...
[2017-12-12 14:58:30,736] INFO : [quick-validate] started at: Tue Dec 12 14:58:30 GMT 2017
[2017-12-12 14:58:30,774] ERROR: [quick-validate] error: ZipException[Not in GZIP format]
java.util.zip.ZipException: Not in GZIP format
   at java.util.zip.GZIPInputStream.readHeader(Unknown Source)
   at java.util.zip.GZIPInputStream.<unknown>(Unknown Source)
   at java.util.zip.GZIPInputStream.<unknown>(Unknown Source)
   at com.tchegbe.lib.b.a.a.a.<unknown>(Unknown Source)
   at com.tchegbe.lib.b.a.a.a.<unknown>(Unknown Source)
   at com.tchegbe.lib.b.a.a.a.a(Unknown Source)
   at com.tchegbe.lib.io.a.g.c.<unknown>(Unknown Source)
   at com.tchegbe.lib.io.a.g.c.a(Unknown Source)
   at com.tchegbe.lib.io.a.g.c.<unknown>(Unknown Source)
   at com.tchegbe.lib.io.a.g.c.<unknown>(Unknown Source)
   at com.tchegbe.lib.io.a.e.x.a(Unknown Source)
   at com.tchegbe.lib.io.a.e.c.a.run(Unknown Source)
   at java.lang.Thread.run(Unknown Source)
[2017-12-12 14:58:30,775] INFO : [quick-validate] completed at: Tue Dec 12 14:58:30 GMT 2017

I've deleted and re-installed both FlexRAID and my configuration; neither rectified the problem. It feels like my parity and/or metadata has become corrupt.

Any suggestions please


5
RAID-F on Windows / Re: Latest Version of Raid-F?
« on: March 28, 2017, 01:42:02 am »
Agreed, steer well clear of 2.1; I had to roll-back.

Very concerned that we've seen no bug fixes

6
Snapshot RAID / Re: Update Snapshot RAiD
« on: January 11, 2017, 10:21:10 am »
That doesn't sound normal; but maybe you have a very fragmented array...? Is the array almost full, and you deleted some files to make room for the new 500GB

7
Snapshot RAID / Re: Missing Space
« on: November 24, 2016, 12:56:01 pm »
Insufficient information... but it looks like only your storage pool has 7.28TB; your raid has the full 12TB

8
Snapshot RAID / Re: Help needed : Verify failure: operation aborted! :-(
« on: November 13, 2016, 02:25:06 am »
As was suggested in your other post, revert to v2.0

9
Snapshot RAID / Re: 2.1 problems with verify
« on: November 13, 2016, 02:03:39 am »
I too have the same problem; reverting to v2.0 works fine.

Sadly, despite sending logs to support, no fix or even acknowledgement of a bug has been forthcoming :(

10
Snapshot RAID / Re: PPU drives seemingly missing data after update.
« on: September 22, 2016, 02:13:52 am »
A number of us experienced persistent Verify errors with FlexRAID-2.1-Final-2015-11-01; for some of us, this version is unreliable and we have reverted to 2.0.

Have a look at http://forum.flexraid.com/index.php/topic,5366.0/topicseen.html and http://forum.flexraid.com/index.php/topic,5376.15.html

Still waiting for Brahim to fix... :(

11
General Discussion / Re: General Questions about flexRAID - F
« on: September 03, 2016, 03:33:02 am »
RAID-F doesn't protect against datarot / bitrot per se; however it will (or only maybe if you've run an Update) detect it with Validate or Verify.

I guard against bitrot by creating 1% PAR2 files for all my critical data.

12
Snapshot RAID / Re: Wrong timestamps after restore
« on: August 19, 2016, 04:23:58 am »
For an idea/possible way around this limitation, see point 2 in this old post of mine...
http://forum.flexraid.com/index.php/topic,4629.msg28422.html#msg28422

14
Snapshot RAID / Re: How many hours does it take to initiate a PPU?
« on: May 17, 2016, 02:24:50 am »
Sounds excessive; re-create with my setup of 4x6TB DRU takes 18 hours.

I'd look at your I/O performance.

A little trick to see how far it has progresed, look at the date/time stamps of the *.flxr files on the PPU; they should gradually be changing as FlexRAID runs through your entire data.

15
Unfortunately, I don't have any complete logs; when I reverted to v2.0, I deleted all FlexRAID v2.1 files so as to effect a clean install. Though I do have limited and highly edited extracts - what exactly in the logs do you want to look at? We may be lucky, I may just have something.
And because I'm now on v2.0, I can't reproduce the problem.

Have you had a look at my bug reprot yet? I have described in some details the steps I did to (reliably) reproduce the bug...

I've found an old log, see pm.

Pages: [1] 2 3 ... 7