FlexRAID Support Forum

Feature requests and bug reports => Feature Requests => tRAID Feature Requests => Topic started by: vletroye on August 17, 2014, 04:07:15 pm

Title: Save SMART Monitoring failed due to "Selected monitored attribute"
Post by: vletroye on August 17, 2014, 04:07:15 pm
Not a bug but just a feature a bit annoying...

There is not bulk process to enable SMART Monitoring on all drives.
So I do it one by one, as fast as possible:
- Change the selected device
- enable monitoring
- click save
- Change the selected device
- enable monitoring
- click save
- Change the selected device
- enable monitoring
- click save
- ...


After enabling Monitoring for the first drive, I selected a Monitor Attribute (to have a look).
This selected "Monitor Attributed" was not reset to blank when I moved to the next device...
And unfortunately, this attribute didn't exist for all my disks (E.g.: for SSD).

I didn't notice immediately, but this prevented me to "Save" the option "Monitor this drive"...
It's only later, when checking all my changes one by one, that I noticed the option was not ticked for such disks :-\

If this field may not be cleaned when navigating from a device to another, it should not be "valid" when "saving" changes in the settings...

(http://i.imgur.com/RNOEXM3.png)
Title: Re: Save SMART Monitoring failed due to "Selected monitored attribute"
Post by: Brahim on August 17, 2014, 05:37:49 pm
Fixed the field reset issue.

The build SMART setting should go as a feature request. So, will move the thread there.
Title: Re: Save SMART Monitoring failed due to "Selected monitored attribute"
Post by: vletroye on August 17, 2014, 05:39:01 pm
Ok. And thx for the fix ;)